summaryrefslogtreecommitdiffstats
path: root/package/gstreamer1
diff options
context:
space:
mode:
authorGary Bisson <gary.bisson@boundarydevices.com>2017-11-21 16:27:06 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-11-22 21:30:15 +0100
commit599b3af68aac15969b0909d99bf0ba23ba305ac2 (patch)
treed1c84e5271325efb60fc7e18b1f84c358fa39218 /package/gstreamer1
parent4f50d30a944b1e39c7f3983fcebbd9e7ae8e587f (diff)
downloadbuildroot-599b3af68aac15969b0909d99bf0ba23ba305ac2.tar.gz
buildroot-599b3af68aac15969b0909d99bf0ba23ba305ac2.zip
gst1-imx: fix v4l2 plugins disable options
Latest bump to v0.13.0 didn't take care of the following upstream commit: 7bfbf71 v4l2: Rename to v4l2video and add switches to enable/disable sink/source To address that, this commit: - Uses the new name of the v4l2 source configure script option - Introduce a new Config.in option to control the build of the v4l2 sink support Fixes: http://autobuild.buildroot.net/results/5c404a2a28a4052056e5c9a7edda40641fe55f9e Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gstreamer1')
-rw-r--r--package/gstreamer1/gst1-imx/Config.in6
-rw-r--r--package/gstreamer1/gst1-imx/gst1-imx.mk11
2 files changed, 15 insertions, 2 deletions
diff --git a/package/gstreamer1/gst1-imx/Config.in b/package/gstreamer1/gst1-imx/Config.in
index 9f792d1c82..9b977bdde8 100644
--- a/package/gstreamer1/gst1-imx/Config.in
+++ b/package/gstreamer1/gst1-imx/Config.in
@@ -84,4 +84,10 @@ config BR2_PACKAGE_GST1_IMX_V4L2VIDEOSRC
help
Elements for V4L2 capture
+config BR2_PACKAGE_GST1_IMX_V4L2VIDEOSINK
+ bool "imxv4l2videosink"
+ select BR2_PACKAGE_GST1_PLUGINS_BAD
+ help
+ Elements for V4L2 output
+
endif
diff --git a/package/gstreamer1/gst1-imx/gst1-imx.mk b/package/gstreamer1/gst1-imx/gst1-imx.mk
index c621c360f4..a8fe6fe041 100644
--- a/package/gstreamer1/gst1-imx/gst1-imx.mk
+++ b/package/gstreamer1/gst1-imx/gst1-imx.mk
@@ -83,10 +83,17 @@ GST1_IMX_CONF_OPTS += --disable-vpu
endif
ifeq ($(BR2_PACKAGE_GST1_IMX_V4L2VIDEOSRC),y)
-# There's no --enable-v4l2src option
+# There's no --enable-imxv4l2videosrc option
GST1_IMX_DEPENDENCIES += gst1-plugins-bad
else
-GST1_IMX_CONF_OPTS += --disable-v4l2src
+GST1_IMX_CONF_OPTS += --disable-imxv4l2videosrc
+endif
+
+ifeq ($(BR2_PACKAGE_GST1_IMX_V4L2VIDEOSINK),y)
+# There's no --enable-imxv4l2videosink option
+GST1_IMX_DEPENDENCIES += gst1-plugins-bad
+else
+GST1_IMX_CONF_OPTS += --disable-imxv4l2videosink
endif
$(eval $(waf-package))
OpenPOWER on IntegriCloud