summaryrefslogtreecommitdiffstats
path: root/package/gnupg
diff options
context:
space:
mode:
authorPeter Sanford <psanford@nearbuysystems.com>2013-09-29 17:25:20 -0700
committerPeter Korsgaard <peter@korsgaard.com>2013-10-01 22:01:09 +0200
commitb2fab93b1636027c73c664cdf395cb8f93dc55dc (patch)
treebc52cfdfb71c78425c616d63b2a7370994c9bd2f /package/gnupg
parent300eb6b751bc623a2446ead4c885bcfa84419744 (diff)
downloadbuildroot-b2fab93b1636027c73c664cdf395cb8f93dc55dc.tar.gz
buildroot-b2fab93b1636027c73c664cdf395cb8f93dc55dc.zip
gnupg: option to include RSA support.
gnupg is compiled with --enable-minimal flag. This produces a binary that only supports ElGamal and DSA public key algorithms. RSA has been the default for `gpg --gen-key` since 2009, so it makes sense to be able to build a gnupg binary that supports it. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/gnupg')
-rw-r--r--package/gnupg/Config.in5
-rw-r--r--package/gnupg/gnupg.mk6
2 files changed, 11 insertions, 0 deletions
diff --git a/package/gnupg/Config.in b/package/gnupg/Config.in
index 8ddffaa19f..90f07c24c6 100644
--- a/package/gnupg/Config.in
+++ b/package/gnupg/Config.in
@@ -15,6 +15,11 @@ config BR2_PACKAGE_GNUPG
if BR2_PACKAGE_GNUPG
+config BR2_PACKAGE_GNUPG_RSA
+ bool "RSA support"
+ help
+ Support for RSA public key algorithm
+
config BR2_PACKAGE_GNUPG_GPGV
bool "gpgv"
help
diff --git a/package/gnupg/gnupg.mk b/package/gnupg/gnupg.mk
index f0c4b034c6..38604b5907 100644
--- a/package/gnupg/gnupg.mk
+++ b/package/gnupg/gnupg.mk
@@ -31,6 +31,12 @@ else
GNUPG_CONF_OPT += --without-readline
endif
+ifeq ($(BR2_PACKAGE_GNUPG_RSA),y)
+GNUPG_CONF_OPT += --enable-rsa
+else
+GNUPG_CONF_OPT += --disable-rsa
+endif
+
ifneq ($(BR2_PACKAGE_GNUPG_GPGV),y)
define GNUPG_REMOVE_GPGV
rm -f $(TARGET_DIR)/usr/bin/gpgv \
OpenPOWER on IntegriCloud