summaryrefslogtreecommitdiffstats
path: root/package/glibc
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-02-10 18:43:46 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-13 22:22:54 +0100
commit6762e427dbf0e17177211dfcf72034cdc70f663d (patch)
tree580b64472cdf6254ed77fc013b9f3c16f6bf7d4f /package/glibc
parent89673ec0df06b32dda86895f16f18064bc367ce2 (diff)
downloadbuildroot-6762e427dbf0e17177211dfcf72034cdc70f663d.tar.gz
buildroot-6762e427dbf0e17177211dfcf72034cdc70f663d.zip
glibc: add 2.19 as a supported version
glibc 2.19 has been released recently (https://sourceware.org/ml/libc-alpha/2014-02/msg00224.html). This commit allows to build a toolchain with this new version. In order to allow this, we add a version selection that did not exist for glibc. We default to 2.18, which was the only supported version until now, and add an option for 2.19. For microblaze, which uses a specific glibc version, the version selection choice is not displayed. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/glibc')
-rw-r--r--package/glibc/Config.in21
-rw-r--r--package/glibc/glibc.mk2
2 files changed, 22 insertions, 1 deletions
diff --git a/package/glibc/Config.in b/package/glibc/Config.in
new file mode 100644
index 0000000000..a92b5eae4b
--- /dev/null
+++ b/package/glibc/Config.in
@@ -0,0 +1,21 @@
+if BR2_TOOLCHAIN_BUILDROOT_GLIBC
+
+choice
+ prompt "glibc version"
+ default BR2_GLIBC_VERSION_2_18
+ # Architectures supported in mainline glibc
+ depends on BR2_arm || BR2_armeb || BR2_aarch64 || \
+ BR2_i386 || BR2_mips || BR2_mipsel || \
+ BR2_mips64 || BR2_mips64el || BR2_powerpc || \
+ BR2_sh || BR2_sh64 || BR2_sparc || \
+ BR2_x86_64
+
+config BR2_GLIBC_VERSION_2_18
+ bool "2.18"
+
+config BR2_GLIBC_VERSION_2_19
+ bool "2.19"
+
+endchoice
+
+endif
diff --git a/package/glibc/glibc.mk b/package/glibc/glibc.mk
index 96de02a754..89eaaf6de5 100644
--- a/package/glibc/glibc.mk
+++ b/package/glibc/glibc.mk
@@ -21,7 +21,7 @@ GLIBC_SITE = http://downloads.yoctoproject.org/releases/eglibc/
GLIBC_SOURCE = eglibc-$(GLIBC_VERSION).tar.bz2
GLIBC_SRC_SUBDIR = libc
else
-GLIBC_VERSION = 2.18
+GLIBC_VERSION = $(if $(BR2_GLIBC_VERSION_2_19),2.19,2.18)
GLIBC_SITE = $(BR2_GNU_MIRROR)/libc
GLIBC_SOURCE = glibc-$(GLIBC_VERSION).tar.xz
GLIBC_SRC_SUBDIR = .
OpenPOWER on IntegriCloud