summaryrefslogtreecommitdiffstats
path: root/package/glibc/glibc.mk
diff options
context:
space:
mode:
authorFabio Porcedda <fabio.porcedda@gmail.com>2014-02-14 10:55:05 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-14 21:08:45 +0100
commit6c5c08b854e4490697076ae3c5a9c587d8672c63 (patch)
tree47205f2cbee87a9d2930f2a55ae799c883261752 /package/glibc/glibc.mk
parentb2fd9f90e23e25ab6c55f116c2cf3c244d122ec2 (diff)
downloadbuildroot-6c5c08b854e4490697076ae3c5a9c587d8672c63.tar.gz
buildroot-6c5c08b854e4490697076ae3c5a9c587d8672c63.zip
package: add support for top-level parallel make
To be able to use top-level parallel make we must not depend in a rule on the order of evaluation of the prerequisites, so instead of relying on the left to right ordering of evaluation of the prerequisites add an explicit rule to describe the dependencies. We cannot use the pattern rules because they must have the same dependency for every package, but we need to change the dependencies depending on $(2)_OVERRIDE_SRCDIR variable value, so we must use a more flexible way like $(2)_TARGET_% variables. So add explicit dependencies for the following stamp files: $(2)_TARGET_EXTRACT $(2)_TARGET_PATCH $(2)_TARGET_CONFIGURE $(2)_TARGET_BUILD $(2)_TARGET_INSTALL_STAGING $(2)_TARGET_INSTALL_TARGET $(2)_TARGET_INSTALL_IMAGES $(2)_TARGET_INSTALL_HOST Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/glibc/glibc.mk')
-rw-r--r--package/glibc/glibc.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/glibc/glibc.mk b/package/glibc/glibc.mk
index f50b4591bc..6579f4616b 100644
--- a/package/glibc/glibc.mk
+++ b/package/glibc/glibc.mk
@@ -38,9 +38,6 @@ GLIBC_ADD_TOOLCHAIN_DEPENDENCY = NO
# cross-compiler and the kernel headers
GLIBC_DEPENDENCIES = host-gcc-initial linux-headers host-gawk
-# Before (e)glibc is built, we must have the second stage cross-compiler
-glibc-build: host-gcc-intermediate
-
GLIBC_SUBDIR = build
GLIBC_INSTALL_STAGING = YES
@@ -142,3 +139,6 @@ define GLIBC_INSTALL_TARGET_CMDS
endef
$(eval $(autotools-package))
+
+# Before (e)glibc is built, we must have the second stage cross-compiler
+$(GLIBC_TARGET_BUILD): | host-gcc-intermediate
OpenPOWER on IntegriCloud