summaryrefslogtreecommitdiffstats
path: root/package/ffmpeg/ffmpeg.mk
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2015-10-14 16:58:22 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-10-14 22:30:19 +0200
commitb090dcbf90900b971d59017c789ce4e6cd61ae95 (patch)
tree8d976258f267acb7ea92d756d56798ab5e5560ff /package/ffmpeg/ffmpeg.mk
parenta173a5e3d848c2d52b936289ce1b1ef764761b70 (diff)
downloadbuildroot-b090dcbf90900b971d59017c789ce4e6cd61ae95.tar.gz
buildroot-b090dcbf90900b971d59017c789ce4e6cd61ae95.zip
ffmpeg: disable MIPS DSP options by default
DSP support depends on the core implementation, not on the ISA, so enabling it for mips64r2 is not correct since you can build a mips64r2 core without DSP support. Disable mipsdspr1 and mipsdspr2 options by default and let the user enable them via the BR2_PACKAGE_FFMPEG_EXTRACONF kconfig option, which will take preference and override the default values. Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/ffmpeg/ffmpeg.mk')
-rw-r--r--package/ffmpeg/ffmpeg.mk12
1 files changed, 2 insertions, 10 deletions
diff --git a/package/ffmpeg/ffmpeg.mk b/package/ffmpeg/ffmpeg.mk
index 4f4c52cbd3..fd953d6152 100644
--- a/package/ffmpeg/ffmpeg.mk
+++ b/package/ffmpeg/ffmpeg.mk
@@ -41,6 +41,8 @@ FFMPEG_CONF_OPTS = \
--enable-runtime-cpudetect \
--disable-hardcoded-tables \
--disable-memalign-hack \
+ --disable-mipsdspr1 \
+ --disable-mipsdspr2 \
--disable-msa \
--enable-hwaccels \
--disable-avisynth \
@@ -355,16 +357,6 @@ FFMPEG_CONF_OPTS += \
--disable-mips32r2
endif
-ifeq ($(BR2_mips_64r2),y)
-FFMPEG_CONF_OPTS += \
- --enable-mipsdspr1 \
- --enable-mipsdspr2
-else
-FFMPEG_CONF_OPTS += \
- --disable-mipsdspr1 \
- --disable-mipsdspr2
-endif
-
ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),y)
FFMPEG_CONF_OPTS += --enable-altivec
else
OpenPOWER on IntegriCloud