summaryrefslogtreecommitdiffstats
path: root/package/fbtft/fbtft.mk
diff options
context:
space:
mode:
authorPeter Seiderer <ps.report@gmx.net>2015-01-03 21:01:47 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-10 15:25:31 +0100
commit9b2bbe3422d1e96eaf1e7f09743c325b48023ac2 (patch)
treed89935f4c784df651ecb83f43e488c390a311015 /package/fbtft/fbtft.mk
parentce36c35c420dc9bff7d7f62490e4eb1e47d1a9dd (diff)
downloadbuildroot-9b2bbe3422d1e96eaf1e7f09743c325b48023ac2.tar.gz
buildroot-9b2bbe3422d1e96eaf1e7f09743c325b48023ac2.zip
linux: add fbtft kernel extension
Tested with RaspberryPi B+ and PiTFT Mini Kit - 320x240 2.8" TFT (see [1] and [2]) and the following target configuration changes: - cmdline.txt: add 'fbcon=map:10 fbcon=font:VGA8x8' - add /etc/modules-load.d/fbtft.conf with 'fbtft_device' - add /etc/modprobe.d/00-fbtft.conf with 'options fbtft_device name=adafruit28 rotate=90 gpios=dc:25' [1] http://h65951.serverkompetenz.net/PeterSeiderer/upload/PiTFT_2_8_ct/Image9893.jpg [2] http://h65951.serverkompetenz.net/PeterSeiderer/upload/PiTFT_2_8_ct/Image9897.jpg [Thomas: - Rename prompt of the Linux extension to "FB TFT drivers" - Remove the full name of the kernel config options in the help text. Giving their CONFIG_<foo> name is enough. - Remove the mention of CONFIG_SPI_BCM2708, since this makes the description RaspberryPi specific, while these drivers can work with any SPI controller. - Refactor the code in linux-ext-fbtft.mk to avoid duplication between the < 3.15 and >= 3.15 cases. - Make the fbtft package a promptless package, since there is no point in selecting only this package, without the kernel extension. - Change the license to GPLv2, since it's kernel code.] Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/fbtft/fbtft.mk')
-rw-r--r--package/fbtft/fbtft.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/fbtft/fbtft.mk b/package/fbtft/fbtft.mk
new file mode 100644
index 0000000000..913627dfc9
--- /dev/null
+++ b/package/fbtft/fbtft.mk
@@ -0,0 +1,11 @@
+################################################################################
+#
+# fbtft
+#
+################################################################################
+
+FBTFT_VERSION = 274035404701245e7491c0c6471c5b72ade4d491
+FBTFT_SITE = $(call github,notro,fbtft,$(FBTFT_VERSION))
+FBTFT_LICENSE = GPLv2
+
+$(eval $(generic-package))
OpenPOWER on IntegriCloud