summaryrefslogtreecommitdiffstats
path: root/package/faifa
diff options
context:
space:
mode:
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>2014-05-28 15:39:06 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-06-08 18:30:58 +0200
commit0bd7eb8effd898e796d77986c53e9520807d34ba (patch)
treeb788abd2d540bc1eab22221f94f48f49a7449336 /package/faifa
parentc96233807032d3f32628e16cba9456b7dcee34aa (diff)
downloadbuildroot-0bd7eb8effd898e796d77986c53e9520807d34ba.tar.gz
buildroot-0bd7eb8effd898e796d77986c53e9520807d34ba.zip
faifa: new package
faifa is a library and a cli used to manage PLC hardware that use Intellon chipset. Almost everybody use theses chips nowadays. [Thomas: license is GPLv2+, not GPLv2. Fix indentation. Add dependency on host-autoconf and a comment to explain what's going on. Fix indentation of target/staging installation commands. Mark the package as not available for static library builds as it always build a shared library. Rewrap Config.in help text.] Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/faifa')
-rw-r--r--package/faifa/Config.in15
-rw-r--r--package/faifa/faifa.mk39
2 files changed, 54 insertions, 0 deletions
diff --git a/package/faifa/Config.in b/package/faifa/Config.in
new file mode 100644
index 0000000000..2acd505779
--- /dev/null
+++ b/package/faifa/Config.in
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_FAIFA
+ bool "faifa"
+ select BR2_PACKAGE_LIBPCAP
+ depends on !BR2_PREFER_STATIC_LIB
+ help
+ Faifa can configure any Intellon-based Power Line
+ Communication device using Intellon INT5000 and INT6000
+ series chips (6000 and 6300 chips). It supports all
+ Intellon-specific management and control frames as well as
+ standard management frames.
+
+ https://dev.open-plc.org
+
+comment "faifa needs a toolchain w/ dynamic library"
+ depends on BR2_PREFER_STATIC_LIB
diff --git a/package/faifa/faifa.mk b/package/faifa/faifa.mk
new file mode 100644
index 0000000000..8f5d258c6c
--- /dev/null
+++ b/package/faifa/faifa.mk
@@ -0,0 +1,39 @@
+################################################################################
+#
+# faifa
+#
+################################################################################
+
+FAIFA_VERSION = aa0b5f90b89a9fd1533137b68ebf85f5437aba53
+FAIFA_SITE = $(call github,ffainelli,faifa,$(FAIFA_VERSION))
+FAIFA_INSTALL_STAGING = YES
+FAIFA_DEPENDENCIES = libpcap host-autoconf
+FAIFA_LICENSE = GPLv2+
+FAIFA_LICENSE_FILES = COPYING
+
+# This package uses autoconf, but not automake, so we need to call
+# their special autogen.sh script, and have custom target and staging
+# installation commands.
+
+define FAIFA_RUN_AUTOGEN
+ cd $(@D) && PATH=$(BR_PATH) ./autogen.sh
+endef
+FAIFA_PRE_CONFIGURE_HOOKS += FAIFA_RUN_AUTOGEN
+
+define FAIFA_INSTALL_TARGET_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+ PREFIX=/usr \
+ STRIP=/bin/true \
+ DESTDIR=$(TARGET_DIR) \
+ install
+endef
+
+define FAIFA_INSTALL_STAGING_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+ PREFIX=/usr \
+ STRIP=/bin/true \
+ DESTDIR=$(STAGING_DIR) \
+ install
+endef
+
+$(eval $(autotools-package))
OpenPOWER on IntegriCloud