summaryrefslogtreecommitdiffstats
path: root/package/efibootmgr/efibootmgr.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2018-03-22 13:51:53 +0100
committerPeter Korsgaard <peter@korsgaard.com>2018-03-22 23:45:47 +0100
commit6898144768e03c68d740406cc6947e503eb31366 (patch)
tree2615c1ac755e3b66c123ccb3a05099536973b0a1 /package/efibootmgr/efibootmgr.mk
parent3bc6d100315553b135e1f4131b50229c66046b71 (diff)
downloadbuildroot-6898144768e03c68d740406cc6947e503eb31366.tar.gz
buildroot-6898144768e03c68d740406cc6947e503eb31366.zip
efibootmgr: bump version
Drop 0001-dont-use-fshort-wchar-when-building.patch and 0003-Remove-extra-const-keywords-gcc-7-gripes-about.patch as they are now upstream. The upstream repo moved to the 'rhboot' github project, so adjust upstream URL in .mk and help text to match. Version 15 introduces build time configuration of the default EFI directory (E.G. the subdirectory in the EFI system partition where the loader is installed). This used to be hardcoded to redhat, but now a value must be specified at build time. Given that, it is unlikely that people relied on the default value so set it to the more sensible 'buildroot'. While we are at it, also add a hash for the license file. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/efibootmgr/efibootmgr.mk')
-rw-r--r--package/efibootmgr/efibootmgr.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/package/efibootmgr/efibootmgr.mk b/package/efibootmgr/efibootmgr.mk
index b32d9cbcfd..cdd500f088 100644
--- a/package/efibootmgr/efibootmgr.mk
+++ b/package/efibootmgr/efibootmgr.mk
@@ -4,12 +4,13 @@
#
################################################################################
-EFIBOOTMGR_VERSION = 14
-EFIBOOTMGR_SITE = $(call github,rhinstaller,efibootmgr,$(EFIBOOTMGR_VERSION))
+EFIBOOTMGR_VERSION = 15
+EFIBOOTMGR_SITE = $(call github,rhboot,efibootmgr,$(EFIBOOTMGR_VERSION))
EFIBOOTMGR_LICENSE = GPL-2.0+
EFIBOOTMGR_LICENSE_FILES = COPYING
EFIBOOTMGR_DEPENDENCIES = efivar $(TARGET_NLS_DEPENDENCIES)
EFIBOOTMGR_LDFLAGS = $(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)
+EFIBOOTMGR_MAKE_ARGS = EFIDIR=buildroot
define EFIBOOTMSR_PATCH_HEADER_PATH
$(SED) 's,-I/,-I$(STAGING_DIR)/,' $(@D)/Makefile
@@ -19,12 +20,13 @@ EFIBOOTMGR_POST_PATCH_HOOKS += EFIBOOTMSR_PATCH_HEADER_PATH
define EFIBOOTMGR_BUILD_CMDS
$(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) \
- LDFLAGS="$(EFIBOOTMGR_LDFLAGS)" $(MAKE1) -C $(@D)
+ LDFLAGS="$(EFIBOOTMGR_LDFLAGS)" $(MAKE1) -C $(@D) \
+ $(EFIBOOTMGR_MAKE_ARGS)
endef
define EFIBOOTMGR_INSTALL_TARGET_CMDS
$(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
- DESTDIR=$(TARGET_DIR) install
+ $(EFIBOOTMGR_MAKE_ARGS) DESTDIR=$(TARGET_DIR) install
endef
$(eval $(generic-package))
OpenPOWER on IntegriCloud