summaryrefslogtreecommitdiffstats
path: root/package/dropwatch
diff options
context:
space:
mode:
authorSimon Dawson <spdawson@gmail.com>2013-11-05 07:55:14 +0000
committerPeter Korsgaard <peter@korsgaard.com>2013-11-05 14:25:51 +0100
commitda1ca5c0a24e12bff1157fbd9275b5150f2ab620 (patch)
treef157bcd8bd24c35a419cd4b5e3acb7012b71fa1d /package/dropwatch
parentc6e69598a3e801267d23f3e29a030b1ea13878c5 (diff)
downloadbuildroot-da1ca5c0a24e12bff1157fbd9275b5150f2ab620.tar.gz
buildroot-da1ca5c0a24e12bff1157fbd9275b5150f2ab620.zip
dropwatch: fix avr32 build failure
On avr32, dropwatch needs libiberty to avoid build failures such as http://autobuild.buildroot.net/results/cd5/cd5e22fb5c9b0fc5d396bc85a5e253a1a65054da/ Also test built on ARM. [Peter: pass TARGET_LDFLAGS as well, append -lintl in gettext case] Signed-off-by: Simon Dawson <spdawson@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/dropwatch')
-rw-r--r--package/dropwatch/dropwatch.mk9
1 files changed, 7 insertions, 2 deletions
diff --git a/package/dropwatch/dropwatch.mk b/package/dropwatch/dropwatch.mk
index 5d65d86699..6bbcb234c8 100644
--- a/package/dropwatch/dropwatch.mk
+++ b/package/dropwatch/dropwatch.mk
@@ -13,13 +13,18 @@ DROPWATCH_LICENSE_FILES = COPYING
# libbfd may be linked to libintl
# Ugly... but LDFLAGS are hardcoded anyway
+#
+# Also: always need to add -liberty to hardcoded LDFLAGS for avr32
+DROPWATCH_LDFLAGS = \
+ $(TARGET_LDFLAGS) -lbfd -liberty -lreadline -lnl-3 -lnl-genl-3
+
ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
-DROPWATCH_LDFLAGS = LDFLAGS="-lintl -lbfd -lreadline -lnl-3 -lnl-genl-3"
+DROPWATCH_LDFLAGS += -lintl
endif
define DROPWATCH_BUILD_CMDS
$(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
- $(DROPWATCH_LDFLAGS) build
+ LDFLAGS="$(DROPWATCH_LDFLAGS)" build
endef
define DROPWATCH_CLEAN_CMDS
OpenPOWER on IntegriCloud