summaryrefslogtreecommitdiffstats
path: root/package/docker-engine
diff options
context:
space:
mode:
authorChristian Stewart <christian@paral.in>2017-04-18 03:53:59 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-04-18 17:46:37 +0200
commit5d5b92f229ab69e704ef3d4cfb47c20d8b0d3c50 (patch)
treee2cfc8b55eac238c081174585ace278854070ae0 /package/docker-engine
parent22137aa46067b66a2b1fc0865922833a8fe4d620 (diff)
downloadbuildroot-5d5b92f229ab69e704ef3d4cfb47c20d8b0d3c50.tar.gz
buildroot-5d5b92f229ab69e704ef3d4cfb47c20d8b0d3c50.zip
docker-engine: fix handling of vendor tree
The latest docker-engine release changes the vendor tree slightly. The Go tool will recognize a ./vendor directory and use it as a vendor tree automatically, but only when run inside a valid GOPATH. This patch adjusts how the GOPATH is built - now docker/docker is linked into a blank tree, and the Go tool recognizes the ./vendor directory correctly. Signed-off-by: Christian Stewart <christian@paral.in> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/docker-engine')
-rw-r--r--package/docker-engine/docker-engine.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/docker-engine/docker-engine.mk b/package/docker-engine/docker-engine.mk
index 5101702045..c4c1157f43 100644
--- a/package/docker-engine/docker-engine.mk
+++ b/package/docker-engine/docker-engine.mk
@@ -13,7 +13,7 @@ DOCKER_ENGINE_LICENSE_FILES = LICENSE
DOCKER_ENGINE_DEPENDENCIES = host-go host-pkgconf
-DOCKER_ENGINE_GOPATH = "$(@D)/vendor"
+DOCKER_ENGINE_GOPATH = "$(@D)/gopath"
DOCKER_ENGINE_MAKE_ENV = $(HOST_GO_TARGET_ENV) \
CGO_ENABLED=1 \
CGO_NO_EMULATION=1 \
@@ -100,7 +100,8 @@ endif
define DOCKER_ENGINE_BUILD_CMDS
$(foreach target,$(DOCKER_ENGINE_BUILD_TARGETS), \
- cd $(@D); $(DOCKER_ENGINE_MAKE_ENV) \
+ cd $(@D)/gopath/src/github.com/docker/docker; \
+ $(DOCKER_ENGINE_MAKE_ENV) \
$(HOST_DIR)/usr/bin/go build -v \
-o $(@D)/bin/$(target) \
-tags "$(DOCKER_ENGINE_BUILD_TAGS)" \
OpenPOWER on IntegriCloud