summaryrefslogtreecommitdiffstats
path: root/package/docker-engine
diff options
context:
space:
mode:
authorChristian Stewart <christian@paral.in>2016-12-23 22:02:46 -0800
committerPeter Korsgaard <peter@korsgaard.com>2016-12-25 23:09:35 +0100
commit0533484eb7e2ff8500406035c59d2c3c2c07dda3 (patch)
tree24c61dac9577713c994ac45e98b74665ea782aa1 /package/docker-engine
parent2db9867da9bc43dad29de4678273e1b508b4c535 (diff)
downloadbuildroot-0533484eb7e2ff8500406035c59d2c3c2c07dda3.tar.gz
buildroot-0533484eb7e2ff8500406035c59d2c3c2c07dda3.zip
docker-engine: fix docker version output
At compile-time the docker build scripts generate a version file used to build the output of the docker version command. This file is generated somewhat properly by the Buildroot build system, however the version number and commit ID are incorrectly formatted. This patch fixes the output to the correct format. This is important as some tools like WeaveWorks won't even start unless they can parse the Docker Version output correctly. [Peter: strip v from version using patsusbt] Signed-off-by: Christian Stewart <christian@paral.in> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/docker-engine')
-rw-r--r--package/docker-engine/docker-engine.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/docker-engine/docker-engine.mk b/package/docker-engine/docker-engine.mk
index ade6fbb02a..2cd71dd898 100644
--- a/package/docker-engine/docker-engine.mk
+++ b/package/docker-engine/docker-engine.mk
@@ -5,6 +5,7 @@
################################################################################
DOCKER_ENGINE_VERSION = v1.12.5
+DOCKER_ENGINE_COMMIT = 7392c3b0ce0f9d3e918a321c66668c5d1ef4f689
DOCKER_ENGINE_SITE = $(call github,docker,docker,$(DOCKER_ENGINE_VERSION))
DOCKER_ENGINE_LICENSE = Apache-2.0
@@ -67,7 +68,9 @@ endif
define DOCKER_ENGINE_CONFIGURE_CMDS
ln -fs $(@D) $(DOCKER_ENGINE_GOPATH)/src/github.com/docker/docker
cd $(@D) && \
- GITCOMMIT="unknown" BUILDTIME="$$(date)" VERSION="$(DOCKER_ENGINE_VERSION)" \
+ GITCOMMIT="$$(echo $(DOCKER_ENGINE_COMMIT) | head -c7)" \
+ BUILDTIME="$$(date)" \
+ VERSION="$(patsubst v%,%,$(DOCKER_ENGINE_VERSION))" \
PKG_CONFIG="$(PKG_CONFIG_HOST_BINARY)" $(TARGET_MAKE_ENV) \
bash ./hack/make/.go-autogen
endef
OpenPOWER on IntegriCloud