summaryrefslogtreecommitdiffstats
path: root/package/dnsmasq
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2014-06-12 10:46:41 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-06-12 10:46:41 +0200
commitcbf2ae296ed08bee10945e9ca95459adbf793c67 (patch)
treedfa85c4e9abd94a40a4c45015cac0c68fc53d357 /package/dnsmasq
parent11dbb615338cd768acc2c3138064ddf557e9b60b (diff)
downloadbuildroot-cbf2ae296ed08bee10945e9ca95459adbf793c67.tar.gz
buildroot-cbf2ae296ed08bee10945e9ca95459adbf793c67.zip
dnsmasq: static linking with lua doesn't need -ldl
Fixes http://autobuild.buildroot.net/results/77e/77e4123a3ddc934efedf4b09adc2436421ee70b3/ liblua only uses libdl when dynamic linking is used, and certain toolchains (E.G. bfin) doesn't provide a libdl - So only link against it if it is needed. At the same time change it pass the library in LIBS instead of LDFLAGS so it ends up at the end of the linker cmdline. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/dnsmasq')
-rw-r--r--package/dnsmasq/dnsmasq.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/dnsmasq/dnsmasq.mk b/package/dnsmasq/dnsmasq.mk
index dd15994aaf..71d2f30290 100644
--- a/package/dnsmasq/dnsmasq.mk
+++ b/package/dnsmasq/dnsmasq.mk
@@ -55,7 +55,11 @@ endif
ifeq ($(BR2_PACKAGE_DNSMASQ_LUA),y)
DNSMASQ_DEPENDENCIES += lua
- DNSMASQ_MAKE_OPT += LDFLAGS+="-ldl"
+
+# liblua uses dlopen when dynamically linked
+ifneq ($(BR2_PREFER_STATIC_LIB),y)
+ DNSMASQ_MAKE_OPT += LIBS="-ldl"
+endif
define DNSMASQ_ENABLE_LUA
$(SED) 's/lua5.1/lua/g' $(DNSMASQ_DIR)/Makefile
OpenPOWER on IntegriCloud