summaryrefslogtreecommitdiffstats
path: root/package/daemon/daemon.mk
diff options
context:
space:
mode:
authorBaruch Siach <baruch@tkos.co.il>2017-05-08 21:01:47 +0300
committerPeter Korsgaard <peter@korsgaard.com>2017-05-09 17:13:20 +0200
commitc23236d387a84a73940b490f363c3d3d364e3c96 (patch)
treea6f1e09ec165942105a9ec82a5f50828070cdeb7 /package/daemon/daemon.mk
parentc1d1879abaa4f5c7c9c8f0d7304ebb683dc9c679 (diff)
downloadbuildroot-c23236d387a84a73940b490f363c3d3d364e3c96.tar.gz
buildroot-c23236d387a84a73940b490f363c3d3d364e3c96.zip
daemon: fix parallel build
The 'ready' target creates a symlink in the libslack/ subdirectory to make up the path to header files. Unfortunately, the target building sources files that need that symlink, does not depend on the 'ready' target. This might break highly parallel builds. As a workaround make the 'ready' target before making 'all'. Should fix: http://autobuild.buildroot.net/results/ed2/ed21ac166f2151aa69a7790a17ff05f05afa512d/ http://autobuild.buildroot.net/results/333/3338539743c8b0399c6b0fcbbb7c28b58bf3f387/ Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/daemon/daemon.mk')
-rw-r--r--package/daemon/daemon.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/daemon/daemon.mk b/package/daemon/daemon.mk
index dfa573f426..79cf3f7aab 100644
--- a/package/daemon/daemon.mk
+++ b/package/daemon/daemon.mk
@@ -14,6 +14,7 @@ define DAEMON_CONFIGURE_CMDS
endef
define DAEMON_BUILD_CMDS
+ $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) ready
$(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
endef
OpenPOWER on IntegriCloud