summaryrefslogtreecommitdiffstats
path: root/package/cargo
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-12-28 14:25:50 +0100
committerPeter Korsgaard <peter@korsgaard.com>2019-01-17 23:01:11 +0100
commitb5e1b51dd1ee68ee342a3340c9c947c083861eb8 (patch)
tree9eff6bd609969f1039c522ef1bc52071948e7c9d /package/cargo
parent5d882b71a8c0c87b0ccdea7ad620a8f44c33fcb1 (diff)
downloadbuildroot-b5e1b51dd1ee68ee342a3340c9c947c083861eb8.tar.gz
buildroot-b5e1b51dd1ee68ee342a3340c9c947c083861eb8.zip
package/cargo: pass appropriate library path to the linker
When linking the host cargo binary, the linker should be told to find libraries in $(HOST_DIR)/lib, otherwise it will not work libraries such as libhttp_parser. This was found with per-package directory support, where the build failed with: = note: /usr/bin/ld: cannot find -lhttp_parser collect2: error: ld returned 1 exit status In order to fix this, instead of passing -L$(HOST_DIR)/lib during the build of Cargo, we make sure all flags in $(HOST_LDFLAGS) are passed. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/cargo')
-rw-r--r--package/cargo/cargo.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/cargo/cargo.mk b/package/cargo/cargo.mk
index 1b1053ba41..a387281b4c 100644
--- a/package/cargo/cargo.mk
+++ b/package/cargo/cargo.mk
@@ -70,7 +70,7 @@ HOST_CARGO_SNAP_OPTS = \
$(if $(VERBOSE),--verbose)
HOST_CARGO_ENV = \
- RUSTFLAGS="-Clink-arg=-Wl,-rpath,$(HOST_DIR)/lib" \
+ RUSTFLAGS="$(addprefix -Clink-arg=,$(HOST_LDFLAGS))" \
CARGO_HOME=$(HOST_CARGO_HOME)
define HOST_CARGO_BUILD_CMDS
OpenPOWER on IntegriCloud