summaryrefslogtreecommitdiffstats
path: root/package/botan
diff options
context:
space:
mode:
authorTobias Blass <tobias.blass@rohde-schwarz.com>2017-06-06 16:29:11 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-06-06 21:44:20 +0200
commite654839f9e2cc6d2780916d0288941cb3d4555dd (patch)
tree9c519fc00db6d11da823fe01385caecd5162af84 /package/botan
parent017d105a6f30b450303effdbdcbac9905c94e870 (diff)
downloadbuildroot-e654839f9e2cc6d2780916d0288941cb3d4555dd.tar.gz
buildroot-e654839f9e2cc6d2780916d0288941cb3d4555dd.zip
botan: disable AltiVec if the CPU does not support it
Botan compiles all PowerPC code with AltiVec support and only determines at runtime whether the CPU even supports it. If the target CPU uses the older SPE extensions, though, this is too late; since SPE and AltiVec are incompatible, gcc aborts the compilation. This patch explicitly disables AltiVec support unless BR2_POWERPC_CPU_HAS_ALTIVEC is defined Signed-off-by: Tobias Blass <tobias.blass@rohde-schwarz.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/botan')
-rw-r--r--package/botan/botan.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/botan/botan.mk b/package/botan/botan.mk
index 2f2415170c..e42bb61cbe 100644
--- a/package/botan/botan.mk
+++ b/package/botan/botan.mk
@@ -43,6 +43,12 @@ BOTAN_DEPENDENCIES += zlib
BOTAN_CONF_OPTS += --with-zlib
endif
+ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),y)
+BOTAN_CONF_OPTS += --enable-altivec
+else
+BOTAN_CONF_OPTS += --disable-altivec
+endif
+
define BOTAN_CONFIGURE_CMDS
(cd $(@D); $(TARGET_MAKE_ENV) ./configure.py $(BOTAN_CONF_OPTS))
endef
OpenPOWER on IntegriCloud