summaryrefslogtreecommitdiffstats
path: root/package/bluez5_utils
diff options
context:
space:
mode:
authorAndy Shevchenko <andriy.shevchenko@linux.intel.com>2017-05-01 15:59:43 +0300
committerPeter Korsgaard <peter@korsgaard.com>2017-05-05 14:36:29 +0200
commit9af3ba604cb21ea735f243fe7196d2c560e10ec0 (patch)
treed5f8e8de4e708eea443ba98c2b71fe0986e72934 /package/bluez5_utils
parent8c76c028bc552d6f3f0e33ce35915b1e034e7178 (diff)
downloadbuildroot-9af3ba604cb21ea735f243fe7196d2c560e10ec0.tar.gz
buildroot-9af3ba604cb21ea735f243fe7196d2c560e10ec0.zip
bluez5_utils: allow enabling formerly experimental plugins
Disregard to increase just minor version BlueZ 5.44 is drastically different in a way what plugins that used to be enabled by the --enable-experimental configure option, now have their own option. Extend Buildroot package to cover these plugins. Cc: Marcin Bis <marcin@bis.org.pl> Cc: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com> Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/bluez5_utils')
-rw-r--r--package/bluez5_utils/Config.in15
-rw-r--r--package/bluez5_utils/bluez5_utils.mk21
2 files changed, 36 insertions, 0 deletions
diff --git a/package/bluez5_utils/Config.in b/package/bluez5_utils/Config.in
index f8e3540ec5..181003b42c 100644
--- a/package/bluez5_utils/Config.in
+++ b/package/bluez5_utils/Config.in
@@ -61,6 +61,21 @@ config BR2_PACKAGE_BLUEZ5_UTILS_EXPERIMENTAL
help
Build BlueZ 5.x experimental Nokia OBEX PC Suite plugin
+config BR2_PACKAGE_BLUEZ5_PLUGINS_HEALTH
+ bool "build health plugin"
+ help
+ Build BlueZ 5.x health plugin
+
+config BR2_PACKAGE_BLUEZ5_PLUGINS_NFC
+ bool "build nfc plugin"
+ help
+ Build BlueZ 5.x nfc plugin
+
+config BR2_PACKAGE_BLUEZ5_PLUGINS_SAP
+ bool "build sap plugin"
+ help
+ Build BlueZ 5.x sap plugin
+
config BR2_PACKAGE_BLUEZ5_PLUGINS_SIXAXIS
bool "build sixaxis plugin"
depends on BR2_PACKAGE_HAS_UDEV
diff --git a/package/bluez5_utils/bluez5_utils.mk b/package/bluez5_utils/bluez5_utils.mk
index fac7958002..431783997d 100644
--- a/package/bluez5_utils/bluez5_utils.mk
+++ b/package/bluez5_utils/bluez5_utils.mk
@@ -38,6 +38,27 @@ else
BLUEZ5_UTILS_CONF_OPTS += --disable-experimental
endif
+# enable health plugin
+ifeq ($(BR2_PACKAGE_BLUEZ5_PLUGINS_HEALTH),y)
+BLUEZ5_UTILS_CONF_OPTS += --enable-health
+else
+BLUEZ5_UTILS_CONF_OPTS += --disable-health
+endif
+
+# enable nfc plugin
+ifeq ($(BR2_PACKAGE_BLUEZ5_PLUGINS_NFC),y)
+BLUEZ5_UTILS_CONF_OPTS += --enable-nfc
+else
+BLUEZ5_UTILS_CONF_OPTS += --disable-nfc
+endif
+
+# enable sap plugin
+ifeq ($(BR2_PACKAGE_BLUEZ5_PLUGINS_SAP),y)
+BLUEZ5_UTILS_CONF_OPTS += --enable-sap
+else
+BLUEZ5_UTILS_CONF_OPTS += --disable-sap
+endif
+
# enable sixaxis plugin
ifeq ($(BR2_PACKAGE_BLUEZ5_PLUGINS_SIXAXIS),y)
BLUEZ5_UTILS_CONF_OPTS += --enable-sixaxis
OpenPOWER on IntegriCloud