summaryrefslogtreecommitdiffstats
path: root/package/binutils
diff options
context:
space:
mode:
authorPeter Kümmel <syntheticpp@gmx.net>2015-03-06 13:34:06 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-07 15:01:53 +0100
commit814f63ec32585f281855587fe0a287cee32e4232 (patch)
treec0ed8855f0431ae8e4b32fbba73bcfb1669c5d79 /package/binutils
parent518cdabb896235c8c5c43e9d65a7222961c18579 (diff)
downloadbuildroot-814f63ec32585f281855587fe0a287cee32e4232.tar.gz
buildroot-814f63ec32585f281855587fe0a287cee32e4232.zip
toolchain: add link-time-optimization support
Add a new option BR2_GCC_ENABLE_LTO that builds gcc and binutils with LTO support. Individual packages still have to enable LTO explicitly by passing '-flto' to GCC, which passes it on to the linker. This option does not add that flag globally. Some packages detect if the compiler supports LTO and enable the flag if it does. To support LTO, ar and ranlib must be called with an argument which triggers the usage of the LTO plugin. Since GCC doesn't call these tools itself, it instead provides wrappers for ar and ranlib that pass the LTO arguments. This way existing Makefiles don't need to be changed for LTO support. However, these wrappers are called <tuple>-gcc-ar which matches the pattern to link to the buildroot wrapper in the external toolchain logic. So the external toolchain logic is updated to provide the correct symlink. [Thomas: - Add a separate BR2_BINUTILS_ENABLE_LTO option to enable LTO support in binutils. This is a blind option, selected by BR2_GCC_ENABLE_LTO. It just avoids having binutils.mk poke directly into gcc Config.in options. - Remove the check on the AVR32 special gcc version, which we don't support anymore. - Adapt the help text of the LTO Config.in option to no longer mention "Since version 4.5", since we only support gcc >= 4.5 in Buildroot anyway. - Fix typo in toolchain-external.mk comment.] Signed-off-by: Peter Kümmel <syntheticpp@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/binutils')
-rw-r--r--package/binutils/Config.in.host3
-rw-r--r--package/binutils/binutils.mk4
2 files changed, 7 insertions, 0 deletions
diff --git a/package/binutils/Config.in.host b/package/binutils/Config.in.host
index d0ed84e059..4049cf6a3e 100644
--- a/package/binutils/Config.in.host
+++ b/package/binutils/Config.in.host
@@ -38,6 +38,9 @@ config BR2_BINUTILS_VERSION
default "2.24" if BR2_BINUTILS_VERSION_2_24
default "2.25" if BR2_BINUTILS_VERSION_2_25
+config BR2_BINUTILS_ENABLE_LTO
+ bool
+
config BR2_BINUTILS_EXTRA_CONFIG_OPTIONS
string "Additional binutils options"
default ""
diff --git a/package/binutils/binutils.mk b/package/binutils/binutils.mk
index 9e992533f3..ac62f1f0d2 100644
--- a/package/binutils/binutils.mk
+++ b/package/binutils/binutils.mk
@@ -96,5 +96,9 @@ BINUTILS_PRE_PATCH_HOOKS += BINUTILS_XTENSA_PRE_PATCH
HOST_BINUTILS_PRE_PATCH_HOOKS += BINUTILS_XTENSA_PRE_PATCH
endif
+ifeq ($(BR2_BINUTILS_ENABLE_LTO),y)
+HOST_BINUTILS_CONF_OPTS += --enable-plugins --enable-lto
+endif
+
$(eval $(autotools-package))
$(eval $(host-autotools-package))
OpenPOWER on IntegriCloud