summaryrefslogtreecommitdiffstats
path: root/package/bash
diff options
context:
space:
mode:
authorDaniel Sabogal <dsabogalcc@gmail.com>2017-05-23 13:19:31 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-05-31 22:36:15 +0200
commit43552504c8aacda2a163c933203a3b77146409c1 (patch)
treeed732e88b6b3eb4073266ea216242a0548bd1ec9 /package/bash
parent17aa47fa2cf1cd60809aa70500e8611b6f3abebf (diff)
downloadbuildroot-43552504c8aacda2a163c933203a3b77146409c1.tar.gz
buildroot-43552504c8aacda2a163c933203a3b77146409c1.zip
bash: disable bash malloc by default
Bash's malloc relies on sbrk which is implemented as a fail-only stub in musl. Presently, it is disabled when configured for static libs. Instead, default to using libc malloc. Fixes: # bash bash: xmalloc: locale.c:81: cannot allocate 18 bytes (0 bytes allocated) Signed-off-by: Daniel Sabogal <dsabogalcc@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/bash')
-rw-r--r--package/bash/bash.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/bash/bash.mk b/package/bash/bash.mk
index 639f012045..32c87a659e 100644
--- a/package/bash/bash.mk
+++ b/package/bash/bash.mk
@@ -9,7 +9,7 @@ BASH_SITE = $(BR2_GNU_MIRROR)/bash
# Build after since bash is better than busybox shells
BASH_DEPENDENCIES = ncurses readline host-bison \
$(if $(BR2_PACKAGE_BUSYBOX),busybox)
-BASH_CONF_OPTS = --with-installed-readline
+BASH_CONF_OPTS = --with-installed-readline --without-bash-malloc
BASH_LICENSE = GPL-3.0+
BASH_LICENSE_FILES = COPYING
@@ -24,7 +24,7 @@ BASH_CONF_ENV += \
# The static build needs some trickery
ifeq ($(BR2_STATIC_LIBS),y)
-BASH_CONF_OPTS += --enable-static-link --without-bash-malloc
+BASH_CONF_OPTS += --enable-static-link
# bash wants to redefine the getenv() function. To check whether this is
# possible, AC_TRY_RUN is used which is not possible in
# cross-compilation.
OpenPOWER on IntegriCloud