summaryrefslogtreecommitdiffstats
path: root/package/bash
diff options
context:
space:
mode:
authorJames Knight <james.knight@rockwellcollins.com>2015-09-03 11:00:09 -0400
committerPeter Korsgaard <peter@korsgaard.com>2015-09-04 16:45:42 +0200
commit0610de14901e5ad0f6c9b4db488477db47d2ff57 (patch)
tree8d64f8719536d255ceeef5d8f65adeca59c2e2a0 /package/bash
parent38d1a66bda57cb4c47156021ee976c2583b55822 (diff)
downloadbuildroot-0610de14901e5ad0f6c9b4db488477db47d2ff57.tar.gz
buildroot-0610de14901e5ad0f6c9b4db488477db47d2ff57.zip
package/bash: indicate getcwd is malloc-supported
When Bash attempts to find the current working directory, it uses a C library call `getcwd` to resolve it. When cross-compiling, the configuration process cannot determine if the target system's C library can support an "unfixed" path length. Therefore, Bash will fallback to a size of `PATH_MAX` for determining the current working directory. When using OverlayFS (and possible other file systems), this becomes an issue since file paths can commonly exceed standard `PATH_MAX` length. This typically results in the following error appearing: error retrieving current directory: [...] Common C library `getcwd` calls can default to a higher limit (usually the system's page size). The current configurable C libraries (as of at least 2015.08) support a zero (0) size buffer length. Most use the system's page size; musl, being an exception, which defaults to `PATH_MAX` (as Bash was doing). Since these C libraries support allocating buffer space with a zero (0) provided size, the following configuration change allows Bash to support getting a larger-length'ed working directory on target's that support it. Signed-off-by: James Knight <james.knight@rockwellcollins.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/bash')
-rw-r--r--package/bash/bash.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/bash/bash.mk b/package/bash/bash.mk
index 9865e1971d..97d7182e2f 100644
--- a/package/bash/bash.mk
+++ b/package/bash/bash.mk
@@ -16,6 +16,7 @@ BASH_LICENSE_FILES = COPYING
BASH_CONF_ENV += \
ac_cv_rl_prefix="$(STAGING_DIR)" \
ac_cv_rl_version="$(READLINE_VERSION)" \
+ bash_cv_getcwd_malloc=yes \
bash_cv_job_control_missing=present \
bash_cv_sys_named_pipes=present \
bash_cv_func_sigsetjmp=present \
OpenPOWER on IntegriCloud