summaryrefslogtreecommitdiffstats
path: root/package/avahi/avahi.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-02-07 22:34:24 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-07 23:14:43 +0100
commit92f704a8c120521458610d610fc6e54d032f1345 (patch)
treed9e622005aa828111692233ca195eab2fd6e0012 /package/avahi/avahi.mk
parenteebd770728376106215c519acc4cd74a1b79a141 (diff)
downloadbuildroot-92f704a8c120521458610d610fc6e54d032f1345.tar.gz
buildroot-92f704a8c120521458610d610fc6e54d032f1345.zip
package/avahi: break circular dependencies
We currently have two circular dependency chains: avahi -> libglade -> libgtk2 -> cups -> avahi avahi -> libgtk3 -> cups -> avahi The cups -> avahi dependency makes sense, as cups would be able to use Bonjour and mDNS to find printers, so we want to keep that dependency. The libgtk2 -> cups and libgtk3 -> cups dependencies also make sense, to be able to offer cups in the print dialogs. However, the avahi -> libglade and avahi -> libgtk3 dependencies do not really make sense. As Thomas puts it: The avahi GUI programs seem really useless to me. On Debian/Ubuntu distributions, they are not even packaged within the main avahi packages, but as separate packages, probably indicating that they are not very commonly used. So, we drop the avahi -> libglade and avahi -> libgtk3 dependencies, to break the circular dependency chain. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> [Thomas: add comment in the .mk file.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/avahi/avahi.mk')
-rw-r--r--package/avahi/avahi.mk25
1 files changed, 12 insertions, 13 deletions
diff --git a/package/avahi/avahi.mk b/package/avahi/avahi.mk
index 9c6b609d24..5d6e6a811f 100644
--- a/package/avahi/avahi.mk
+++ b/package/avahi/avahi.mk
@@ -68,9 +68,21 @@ AVAHI_CONF_ENV = \
avahi_cv_sys_cxx_works=yes \
DATADIRNAME=share
+# Note: even if we have Gtk2 and Gtk3 support in Buildroot, we
+# explicitly disable support for them, in order to avoid the following
+# circular dependencies:
+#
+# avahi -> libglade -> libgtk2 -> cups -> avahi
+# avahi -> libgtk3 -> cups -> avahi
+#
+# Since Gtk2 and Gtk3 in Avahi are only used for some example/demo
+# programs, we decided to disable their support to solve the circular
+# dependency.
AVAHI_CONF_OPTS = \
--disable-qt3 \
--disable-qt4 \
+ --disable-gtk \
+ --disable-gtk3 \
--disable-gdbm \
--disable-pygtk \
--disable-mono \
@@ -126,19 +138,6 @@ else
AVAHI_CONF_OPTS += --disable-glib --disable-gobject
endif
-ifeq ($(BR2_PACKAGE_LIBGLADE),y)
-AVAHI_DEPENDENCIES += libglade
-else
-AVAHI_CONF_OPTS += --disable-gtk
-endif
-
-ifeq ($(BR2_PACKAGE_LIBGTK3),y)
-AVAHI_DEPENDENCIES += libgtk3
-AVAHI_CONF_OPTS += --enable-gtk3
-else
-AVAHI_CONF_OPTS += --disable-gtk3
-endif
-
ifeq ($(BR2_PACKAGE_PYTHON),y)
AVAHI_CONF_ENV += \
am_cv_pathless_PYTHON=python \
OpenPOWER on IntegriCloud