summaryrefslogtreecommitdiffstats
path: root/package/avahi/avahi.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-07-03 22:39:02 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-07-05 01:27:20 +0200
commit218bcaeb8d356b3420d203c205f0dd5bab283552 (patch)
tree24f526b007a9c89a56c540f0a1a711d14feec8ef /package/avahi/avahi.mk
parentdfe5708fd7d9e1bc436ec741b8b16c8b27cab66d (diff)
downloadbuildroot-218bcaeb8d356b3420d203c205f0dd5bab283552.tar.gz
buildroot-218bcaeb8d356b3420d203c205f0dd5bab283552.zip
avahi: use new gettext logic
This commit switches to use the new gettext logic, which involves: - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies on gettext/host-gettext - using TARGET_NLS_LIBS to force linking against libintl - dropping BR2_PACKAGE_GETTEXT selection Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Diffstat (limited to 'package/avahi/avahi.mk')
-rw-r--r--package/avahi/avahi.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/avahi/avahi.mk b/package/avahi/avahi.mk
index a356a08291..94b6292b5d 100644
--- a/package/avahi/avahi.mk
+++ b/package/avahi/avahi.mk
@@ -97,8 +97,8 @@ AVAHI_CONF_OPTS = \
--with-autoipd-group=avahi
AVAHI_DEPENDENCIES = \
- $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext) host-intltool \
- host-pkgconf host-gettext
+ host-intltool host-pkgconf \
+ $(TARGET_NLS_DEPENDENCIES)
AVAHI_CFLAGS = $(TARGET_CFLAGS)
@@ -168,7 +168,7 @@ endif
AVAHI_CONF_ENV += CFLAGS="$(AVAHI_CFLAGS)"
-AVAHI_MAKE_OPTS += $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),LIBS=-lintl)
+AVAHI_MAKE_OPTS += LIBS=$(TARGET_NLS_LIBS)
define AVAHI_USERS
avahi -1 avahi -1 * - - -
OpenPOWER on IntegriCloud