summaryrefslogtreecommitdiffstats
path: root/package/atf
diff options
context:
space:
mode:
authorSebastien Bourdelin <sebastien.bourdelin@savoirfairelinux.com>2015-06-11 18:51:31 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-06-12 21:34:28 +0200
commit1f2a7b54edfcb7c052033c7ffa0ba9dd81d7f218 (patch)
tree20420ef84d0ae2b2370e4e5d60a5ba3073c2a738 /package/atf
parentefb58de1804b3dcc42cb963590ff9da54db65f0e (diff)
downloadbuildroot-1f2a7b54edfcb7c052033c7ffa0ba9dd81d7f218.tar.gz
buildroot-1f2a7b54edfcb7c052033c7ffa0ba9dd81d7f218.zip
atf: new package
ATF, or Automated Testing Framework, is a collection of libraries to write test programs in C, C++ and POSIX shell. https://github.com/jmmv/atf Signed-off-by: Sebastien Bourdelin <sebastien.bourdelin@savoirfairelinux.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/atf')
-rw-r--r--package/atf/Config.in11
-rw-r--r--package/atf/atf.hash2
-rw-r--r--package/atf/atf.mk24
3 files changed, 37 insertions, 0 deletions
diff --git a/package/atf/Config.in b/package/atf/Config.in
new file mode 100644
index 0000000000..59712abc2b
--- /dev/null
+++ b/package/atf/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_ATF
+ bool "atf"
+ depends on BR2_INSTALL_LIBSTDCPP
+ help
+ ATF, or Automated Testing Framework, is a collection of
+ libraries to write test programs in C, C++ and POSIX shell.
+
+ https://github.com/jmmv/atf
+
+comment "atf needs a toolchain w/ C++"
+ depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/atf/atf.hash b/package/atf/atf.hash
new file mode 100644
index 0000000000..78cd3c6828
--- /dev/null
+++ b/package/atf/atf.hash
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 92bc64180135eea8fe84c91c9f894e678767764f6dbc8482021d4dde09857505 atf-0.21.tar.gz
diff --git a/package/atf/atf.mk b/package/atf/atf.mk
new file mode 100644
index 0000000000..ed2080e225
--- /dev/null
+++ b/package/atf/atf.mk
@@ -0,0 +1,24 @@
+################################################################################
+#
+# atf
+#
+################################################################################
+
+ATF_VERSION = 0.21
+ATF_SITE = https://github.com/jmmv/atf/releases/download/atf-$(ATF_VERSION)
+ATF_INSTALL_STAGING = YES
+ATF_LICENSE = BSD-2c, BSD-3c
+ATF_LICENSE_FILES = COPYING
+# Ships a beta libtool version hence our patch doesn't apply.
+ATF_AUTORECONF = YES
+# Do not install precompiled tests.
+ATF_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) install-exec
+
+# ATF_SHELL defaults to the host's bash
+ATF_CONF_ENV = \
+ kyua_cv_getopt_plus=yes \
+ kyua_cv_attribute_noreturn=yes \
+ kyua_cv_getcwd_works=yes \
+ ATF_SHELL=/bin/sh
+
+$(eval $(autotools-package))
OpenPOWER on IntegriCloud