summaryrefslogtreecommitdiffstats
path: root/package/agentpp
diff options
context:
space:
mode:
authorLuca Ceresoli <luca@lucaceresoli.net>2014-04-07 00:20:06 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-04-08 01:28:55 +0200
commitc5210ca0e62a520b2d0d7b935300f02b68f18600 (patch)
treee7c475aaa5238735f01b9cda6800358d6a89c082 /package/agentpp
parent4474809aa4b81fc234159e2555d5c0045e18692c (diff)
downloadbuildroot-c5210ca0e62a520b2d0d7b935300f02b68f18600.tar.gz
buildroot-c5210ca0e62a520b2d0d7b935300f02b68f18600.zip
agentpp: new package
[Peter: add threads dependency, style fixes] Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/agentpp')
-rw-r--r--package/agentpp/Config.in20
-rw-r--r--package/agentpp/agentpp.mk20
2 files changed, 40 insertions, 0 deletions
diff --git a/package/agentpp/Config.in b/package/agentpp/Config.in
new file mode 100644
index 0000000000..1442a45758
--- /dev/null
+++ b/package/agentpp/Config.in
@@ -0,0 +1,20 @@
+config BR2_PACKAGE_AGENTPP
+ bool "agent++"
+ select BR2_PACKAGE_SNMPPP
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_TOOLCHAIN_HAS_THREADS # snmp++
+ help
+ AGENT++ is a set of C++ classes which provides a complete protocol
+ engine and dispatch table for the development of SNMP agents.
+ AGENT++ is a multilingual API which supports SNMPv1, SNMPv2c, and
+ SNMPv3. It provides various C++ classes implementing prototypes for
+ scalar and table SNMP managed objects that can be customized by
+ derivation. Additional classes support the development of proxy
+ agents as well as sending notifications.
+
+ SNMPv3 support is enabled if SNMP++ enables it.
+
+ http://www.agentpp.com/agentpp3_5/agentpp3_5.html
+
+comment "agent++ needs a toolchain w/ threads, C++"
+ depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/agentpp/agentpp.mk b/package/agentpp/agentpp.mk
new file mode 100644
index 0000000000..46cdc1d1a4
--- /dev/null
+++ b/package/agentpp/agentpp.mk
@@ -0,0 +1,20 @@
+################################################################################
+#
+# agentpp
+#
+################################################################################
+
+AGENTPP_VERSION = 4.0.2
+AGENTPP_SOURCE = agent++-$(AGENTPP_VERSION).tar.gz
+AGENTPP_SITE = http://www.agentpp.com
+AGENTPP_LICENSE = Apache-2.0
+AGENTPP_LICENSE_FILES = LICENSE-2_0.txt
+AGENTPP_INSTALL_STAGING = YES
+AGENTPP_DEPENDENCIES = host-pkgconf snmppp
+AGENTPP_CONF_OPT += \
+ --disable-proxy \
+ --disable-forwarder \
+ --disable-rpath \
+ --disable-dependency-tracking
+
+$(eval $(autotools-package))
OpenPOWER on IntegriCloud