summaryrefslogtreecommitdiffstats
path: root/package/aespipe/aespipe.mk
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-12-17 08:16:59 +0100
committerPeter Korsgaard <peter@korsgaard.com>2016-12-17 09:19:24 +0100
commitcb33a7d6bd89306635749b497cd004e986bcd7e5 (patch)
tree21def763ffd4b8e94c4daad0446258255a1b1baf /package/aespipe/aespipe.mk
parentc2c31fbeebc53611bf9a975cd9a18659d1236aa2 (diff)
downloadbuildroot-cb33a7d6bd89306635749b497cd004e986bcd7e5.tar.gz
buildroot-cb33a7d6bd89306635749b497cd004e986bcd7e5.zip
package/aespipe: fix host compile
Building host-aespipe fails on $ cat /etc/debian_version stretch/sid at linking stage: /usr/bin/gcc -L/home/buildroot/br6/output/host/lib -L/home/buildroot/br6/output/host/usr/lib -Wl,-rpath,/home/buildroot/br6/output/host/usr/lib -o aespipe aespipe.o aes-amd64.o md5-amd64.o md5-2x-amd64.o aes-intel64.o sha512.o rmd160.o /usr/bin/ld: aes-amd64.o: relocation R_X86_64_32S against `.rodata' can not be used when making a shared object; recompile with -fPIC Fix is also used in Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=837393 [Peter: add comment explaining why] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/aespipe/aespipe.mk')
-rw-r--r--package/aespipe/aespipe.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/aespipe/aespipe.mk b/package/aespipe/aespipe.mk
index 6a38556ef1..8c7cd21850 100644
--- a/package/aespipe/aespipe.mk
+++ b/package/aespipe/aespipe.mk
@@ -9,5 +9,12 @@ AESPIPE_SOURCE = aespipe-v$(AESPIPE_VERSION).tar.bz2
AESPIPE_SITE = http://loop-aes.sourceforge.net/aespipe
AESPIPE_LICENSE = GPL
+# Debian enables -fPIE by default, breaking the build:
+# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=837393
+# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=835148
+HOST_AESPIPE_CONF_ENV = \
+ CFLAGS="$(HOST_CFLAGS) -no-pie" \
+ LDFLAGS="$(HOST_LDFLAGS) -no-pie"
+
$(eval $(autotools-package))
$(eval $(host-autotools-package))
OpenPOWER on IntegriCloud