summaryrefslogtreecommitdiffstats
path: root/package/acpica
diff options
context:
space:
mode:
authorAlistair Francis <alistair.francis@xilinx.com>2017-05-24 13:30:29 -0700
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-05-29 23:47:38 +0200
commitbd6ec23ed350abdf4a9fa208398bc79c510104c9 (patch)
treea5b11fed63342a8d620ee43c09cc5de7157c7a68 /package/acpica
parent2d9f199061fa0629847b63e6b6317a7b12a9d99f (diff)
downloadbuildroot-bd6ec23ed350abdf4a9fa208398bc79c510104c9.tar.gz
buildroot-bd6ec23ed350abdf4a9fa208398bc79c510104c9.zip
package/acpica: add host package
Add support to build the ACPICA package for the host. This is useful for the iasl command which is required to build some packages, including Xen tools. This is a necessary requirement before changing the Xen package to address: http://autobuild.buildroot.net/results/afa199864d6b546fe759bb582a9c10702ea7fa78/ Signed-off-by: Alistair Francis <alistair.francis@xilinx.com> Acked-by: Erico Nunes <nunes.erico@gmail.com> [Thomas: use PREFIX= and not DESTDIR= for host installation, tweak commit log.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/acpica')
-rw-r--r--package/acpica/acpica.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/acpica/acpica.mk b/package/acpica/acpica.mk
index 37e4941a6b..c80989a1ea 100644
--- a/package/acpica/acpica.mk
+++ b/package/acpica/acpica.mk
@@ -17,10 +17,22 @@ define ACPICA_BUILD_CMDS
all
endef
+define HOST_ACPICA_BUILD_CMDS
+ $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+ all
+endef
+
define ACPICA_INSTALL_TARGET_CMDS
$(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
HARDWARE_NAME=$(BR2_ARCH) DESTDIR="$(TARGET_DIR)" \
INSTALLFLAGS=-m755 install
endef
+define HOST_ACPICA_INSTALL_CMDS
+ $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+ PREFIX="$(HOST_DIR)/usr" \
+ INSTALLFLAGS=-m755 install
+endef
+
$(eval $(generic-package))
+$(eval $(host-generic-package))
OpenPOWER on IntegriCloud