summaryrefslogtreecommitdiffstats
path: root/package/acl
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-05-16 14:54:26 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-05-16 15:36:21 +0200
commit5be059c5ae7061de71b8f6c67fe5e66d50f5e6f6 (patch)
tree2b12607197b33efa74838bb91c6dd804881f28d9 /package/acl
parent25e15fd17fa51a79b40159629dea1eea7b5f8d96 (diff)
downloadbuildroot-5be059c5ae7061de71b8f6c67fe5e66d50f5e6f6.tar.gz
buildroot-5be059c5ae7061de71b8f6c67fe5e66d50f5e6f6.zip
acl, attr: fix libdir variable in .la files
The acl and attr packages are using autoconf and libtool, but not automake, which causes all sort of troubles. Some of them are already worked around in acl.mk and attr.mk, but there is another one: the libdir variable in the .la file remains empty, which causes libtool to sometimes be confused about where the acl and attr libraries are installed. This was causing build issues with libarchive, but interestingly only in situations where we had zlib *and* libxml2 also part of the build, which maybe affects how libtool in libarchive behaves since libarchive can use zlib and libxml2 as optional dependencies. So what this patch does is to mungle the libattr.la and libacl.la files to make sure they contain the right libdir values. Yocto is doing exactly the same thing. Upstream attr and acl have been converted fully to automake, so hopefully the upcoming upstream release will allow us to get rid of those hacks, but in the mean time, it seems to be the most appropriate solution. Here is a minimal defconfig that exhibits the problem, and which allows to show that this patch fixes it: BR2_bfin=y BR2_BINFMT_FLAT=y BR2_COMPILER_PARANOID_UNSAFE_PATH=y BR2_INIT_NONE=y BR2_PACKAGE_LIBARCHIVE=y BR2_PACKAGE_LIBARCHIVE_BSDCPIO=y BR2_PACKAGE_ZLIB=y BR2_PACKAGE_LIBXML2=y BR2_PACKAGE_ACL=y Fixes: http://autobuild.buildroot.org/results/e96/e96c8bec1039d9fe8c6c51fd48b6be0dc8be51d7/ (and many, many similar build failures) Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/acl')
-rw-r--r--package/acl/acl.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/acl/acl.mk b/package/acl/acl.mk
index 31bd079a54..62e5d15134 100644
--- a/package/acl/acl.mk
+++ b/package/acl/acl.mk
@@ -27,4 +27,14 @@ ACL_INSTALL_TARGET_OPTS = \
exec_prefix=$(TARGET_DIR)/usr \
install install-lib
+# The libdir variable in libacl.la is empty, so let's fix it. This is
+# probably due to acl not using automake, and not doing fully the
+# right thing with libtool.
+define ACL_FIX_LIBTOOL_LA_LIBDIR
+ $(SED) "s,libdir=.*,libdir='$(STAGING_DIR)'," \
+ $(STAGING_DIR)/usr/lib/libacl.la
+endef
+
+ACL_POST_INSTALL_STAGING_HOOKS += ACL_FIX_LIBTOOL_LA_LIBDIR
+
$(eval $(autotools-package))
OpenPOWER on IntegriCloud