summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-07-04 15:30:26 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-07-27 13:16:50 +0200
commit808cc0a5e17af2c9cd2210cdcbf0d98e79b6e157 (patch)
treeab191e11c37b512748c17f74996fde44247a5156 /package/Makefile.in
parenta8b0a3f87022c1723238f307ad9dddbeaf834d08 (diff)
downloadbuildroot-808cc0a5e17af2c9cd2210cdcbf0d98e79b6e157.tar.gz
buildroot-808cc0a5e17af2c9cd2210cdcbf0d98e79b6e157.zip
toolchain/buildroot: properly handle SSP
The current SSP handling is incomplete. First we need to build uClibc with SSP support for a complete "experience". Second, it doesn't hurt to add -fstack-protector-all to the CFLAGS/CXXFLAGS since most users would expect buildroot to do this rather than adding the flags themselves. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index a597290c23..95eec52dcc 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -124,6 +124,11 @@ TARGET_CFLAGS += -msep-data
TARGET_CXXFLAGS += -msep-data
endif
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT_USE_SSP),y)
+TARGET_CFLAGS += -fstack-protector-all
+TARGET_CXXFLAGS += -fstack-protector-all
+endif
+
ifeq ($(BR2_TOOLCHAIN_BUILDROOT)$(BR2_TOOLCHAIN_CTNG),y)
TARGET_CROSS=$(HOST_DIR)/usr/bin/$(GNU_TARGET_NAME)-
else
OpenPOWER on IntegriCloud