summaryrefslogtreecommitdiffstats
path: root/package/4th
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-06 23:11:16 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-06 23:11:16 +0200
commit9dad02c017706740b02fb7e0858dad218749a353 (patch)
tree354570577d0147fc95a8206963184ab241d935a2 /package/4th
parent5d988ec6f56e6276a5f3f3e98b4dd17b5ac29d91 (diff)
downloadbuildroot-9dad02c017706740b02fb7e0858dad218749a353.tar.gz
buildroot-9dad02c017706740b02fb7e0858dad218749a353.zip
4th: create /usr/lib and /usr/bin before installation
The 4th build system doesn't create the installation directories by itself, causing $(HOST_DIR)/usr/lib to be a file containing the 4th library if $(HOST_DIR)/usr/lib doesn't already exist as a directory. Since 4th is the first package in the build order due to alphabetic ordering, it is very likely that it will install a file as $(HOST_DIR)/usr/lib, breaking the build of follow-up packages. Fixes: http://autobuild.buildroot.net/results/6291046ca0552e11b79a84df4a7844324d78ab97/ http://autobuild.buildroot.net/results/252642b7d6ec3f77142dcbd158f56ed8e2426c25/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/4th')
-rw-r--r--package/4th/4th.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/4th/4th.mk b/package/4th/4th.mk
index bdf0672e2a..d920eb0fa2 100644
--- a/package/4th/4th.mk
+++ b/package/4th/4th.mk
@@ -35,6 +35,8 @@ define 4TH_INSTALL_STAGING_CMDS
endef
define 4TH_INSTALL_TARGET_CMDS
+ mkdir -p $(TARGET_DIR)/usr/bin
+ mkdir -p $(TARGET_DIR)/usr/lib
$(4TH_MAKE_ENV) $(MAKE) -C $(@D)/sources mostlyinstall \
BINARIES=$(TARGET_DIR)/usr/bin \
LIBRARIES=$(TARGET_DIR)/usr/lib
@@ -54,6 +56,8 @@ define HOST_4TH_BUILD_CMDS
endef
define HOST_4TH_INSTALL_CMDS
+ mkdir -p $(HOST_DIR)/usr/bin
+ mkdir -p $(HOST_DIR)/usr/lib
$(MAKE) -C $(@D)/sources mostlyinstall \
BINARIES=$(HOST_DIR)/usr/bin \
LIBRARIES=$(HOST_DIR)/usr/lib
OpenPOWER on IntegriCloud