summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-03-04 22:31:17 +0100
committerPeter Korsgaard <peter@korsgaard.com>2018-03-06 15:25:08 +0100
commitdde090c299b0357fdb1a4ec44ad8d332ac57f65e (patch)
tree133b6d9bec51623684a2b0711cdea9dbe601d72b /linux
parent9f13f8c2374e8240c1b85c702257341df80bd797 (diff)
downloadbuildroot-dde090c299b0357fdb1a4ec44ad8d332ac57f65e.tar.gz
buildroot-dde090c299b0357fdb1a4ec44ad8d332ac57f65e.zip
linux: fix passing of host CFLAGS and LDFLAGS
We were passing HOSTCFLAGS="$(HOSTCFLAGS)" to Linux. However: - HOSTCFLAGS in Buildroot doesn't exist, and is empty, so this assignment never did anything. The name of the variable in Buildroot in HOST_CFLAGS. - HOSTCFLAGS in Linux isn't used everywhere, and passing it overrides the default HOSTCFLAGS value defined in the main Linux kernel Makefile. In addition, there is no way to pass additional host LDFLAGS in the Linux kernel build system. Therefore, we simply shoehorn our HOST_CFLAGS and HOST_LDFLAGS while passing HOSTCC to the Linux kernel build system. This has been tested to work fine with host OpenSSL and host libelf only available in $(HOST_DIR). Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Tested-by: Frank Hunleth <fhunleth@troodon-software.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index ab940e7305..3b69524663 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -95,8 +95,7 @@ LINUX_EXTRA_DOWNLOADS += $(ARCH_XTENSA_OVERLAY_URL)
endif
LINUX_MAKE_FLAGS = \
- HOSTCC="$(HOSTCC)" \
- HOSTCFLAGS="$(HOSTCFLAGS)" \
+ HOSTCC="$(HOSTCC) $(HOST_CFLAGS) $(HOST_LDFLAGS)" \
ARCH=$(KERNEL_ARCH) \
INSTALL_MOD_PATH=$(TARGET_DIR) \
CROSS_COMPILE="$(TARGET_CROSS)" \
OpenPOWER on IntegriCloud