summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
authorAndreas Naumann <anaumann@ultratronik.de>2018-11-13 16:50:16 +0100
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-11-23 22:18:57 +0100
commit860906ee05fad3fe503786ec7c656ea0f25851fc (patch)
tree15a15d2b5ce967d65626a57aebc8a6305777d3d7 /linux
parent1dcea42403cd1c574c4cbabece6fd9eb2fd933e5 (diff)
downloadbuildroot-860906ee05fad3fe503786ec7c656ea0f25851fc.tar.gz
buildroot-860906ee05fad3fe503786ec7c656ea0f25851fc.zip
linux: Make dtc install step more reliable
Checking for the existence of the dtc binary built by the non-dependent dtc package may cause instable behaviour when giving more freedom on the order of how the packages are built (parallelization). In addidion, when moving to per-package host/target method, the check would always trigger in the isolated host, leading to linux-dtc always being installed as dtc. This in turn may lead to undesired overwriting of the real host-dtc binary when finally assembling the global host dir. Thus rework the linux-dtc install condition to be defined by configuration rather than compile time order. Signed-off-by: Andreas Naumann <anaumann@ultratronik.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 476ff16329..864fa772bb 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -461,9 +461,7 @@ define LINUX_INSTALL_HOST_TOOLS
# Installing dtc (device tree compiler) as host tool, if selected
if grep -q "CONFIG_DTC=y" $(@D)/.config; then \
$(INSTALL) -D -m 0755 $(@D)/scripts/dtc/dtc $(HOST_DIR)/bin/linux-dtc ; \
- if [ ! -e $(HOST_DIR)/bin/dtc ]; then \
- ln -sf linux-dtc $(HOST_DIR)/bin/dtc ; \
- fi \
+ $(if $(BR2_PACKAGE_HOST_DTC),,ln -sf linux-dtc $(HOST_DIR)/bin/dtc;) \
fi
endef
OpenPOWER on IntegriCloud