summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2018-12-03 20:12:19 +0100
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-12-06 21:51:23 +0100
commit524fb10bbe2038ea7ca45493193073d31732d1de (patch)
treea3fcd907177400c281e2111d0515266ad769ae5f /linux
parent01b9bdf13e2e97d2e2a8b8225bfc44fd57d022c3 (diff)
downloadbuildroot-524fb10bbe2038ea7ca45493193073d31732d1de.tar.gz
buildroot-524fb10bbe2038ea7ca45493193073d31732d1de.zip
linux: ensure images/ exist before creating files there
When using an initramfs, on the first-pass build, we create a dummy cpio so that the build succeeeds. The real cpio will come later, and we'll do a second-pass build to use the actual cpio. However, when we touch that dummy cpio, the images/ directory may not yet exist, since commit d0f4f95e39 (Makefile: rework main directory creation logic) removed its creation at the begining of the build, to only at the moment we need it, i.e. during the *_INSTALL_IMAGES_CMDS steps. However, the linux build is not a _INSTALL_IMAGES_CMDS step, so there is no guarantee that images/ already exist at that time. Fix that by explicitly creating images/ before touching the dummy cpio. Reported-by: Matthew Weber <matthew.weber@rockwellcollins.com> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Matthew Weber <matthew.weber@rockwellcollins.com> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Reviewed-by: Matthew Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index c00b326e8a..110260723b 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -311,6 +311,7 @@ define LINUX_KCONFIG_FIXUP_CMDS
# replaced later by the real cpio archive, and the kernel will be
# rebuilt using the linux-rebuild-with-initramfs target.
$(if $(BR2_TARGET_ROOTFS_INITRAMFS),
+ mkdir -p $(BINARIES_DIR)
touch $(BINARIES_DIR)/rootfs.cpio
$(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_SOURCE,"$${BR_BINARIES_DIR}/rootfs.cpio",$(@D)/.config)
$(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_ROOT_UID,0,$(@D)/.config)
OpenPOWER on IntegriCloud