summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
authorPhilippe Proulx <eeppeliteloop@gmail.com>2014-07-25 17:25:32 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-28 22:35:12 +0200
commit5224cdcc14b11addbfc3a470cd496966d0b378bc (patch)
tree34772820e8c28e511e220a32e95da8cb01484eb3 /linux
parent353e223d1471604f2c059d10a176b94a68e408ae (diff)
downloadbuildroot-5224cdcc14b11addbfc3a470cd496966d0b378bc.tar.gz
buildroot-5224cdcc14b11addbfc3a470cd496966d0b378bc.zip
linux: support multiple custom DTS files
[Thomas: fix minor typo in help text.] Signed-off-by: Philippe Proulx <eeppeliteloop@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/Config.in6
-rw-r--r--linux/linux.mk2
2 files changed, 5 insertions, 3 deletions
diff --git a/linux/Config.in b/linux/Config.in
index 441301f1b5..825dd3bf93 100644
--- a/linux/Config.in
+++ b/linux/Config.in
@@ -323,10 +323,12 @@ config BR2_LINUX_KERNEL_INTREE_DTS_NAME
dts files to build, separated by spaces.
config BR2_LINUX_KERNEL_CUSTOM_DTS_PATH
- string "Device Tree Source file path"
+ string "Device Tree Source file paths"
depends on BR2_LINUX_KERNEL_USE_CUSTOM_DTS
help
- Path to the device tree source file
+ Path to the device tree source files. You can
+ provide a list of dts paths to copy and build,
+ separated by spaces.
endif
diff --git a/linux/linux.mk b/linux/linux.mk
index 2a9bf3e55f..a5699f9d7d 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -264,7 +264,7 @@ endif
# configuration has changed.
define LINUX_BUILD_CMDS
$(if $(BR2_LINUX_KERNEL_USE_CUSTOM_DTS),
- cp $(BR2_LINUX_KERNEL_CUSTOM_DTS_PATH) $(KERNEL_ARCH_PATH)/boot/dts/)
+ cp $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_DTS_PATH)) $(KERNEL_ARCH_PATH)/boot/dts/)
$(TARGET_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) $(LINUX_TARGET_NAME)
@if grep -q "CONFIG_MODULES=y" $(@D)/.config; then \
$(TARGET_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) modules ; \
OpenPOWER on IntegriCloud