summaryrefslogtreecommitdiffstats
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-08-16 22:45:23 +0200
committerPeter Korsgaard <peter@korsgaard.com>2018-08-17 16:52:00 +0200
commit1b53b177a638eff051caf017d3f4b92cbb52223b (patch)
tree9c896fa4ff8c50b37679682f7565364d31bd4fc5 /linux/linux.mk
parent1ee626aab95f63105551334f7f29c9096436bfe9 (diff)
downloadbuildroot-1b53b177a638eff051caf017d3f4b92cbb52223b.tar.gz
buildroot-1b53b177a638eff051caf017d3f4b92cbb52223b.zip
linux: replace shell for loop with make foreach loop
This commit replaces the loop copying out-of-tree DTS into the kernel tree by a make foreach loop instead of a shell for loop. This allows to error out if one of the DTS file cannot be copied (for example if it doesn't exist). Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 7527b11673..e0d437427d 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -389,9 +389,9 @@ endif
# Compilation. We make sure the kernel gets rebuilt when the
# configuration has changed.
define LINUX_BUILD_CMDS
- @for dts in $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_DTS_PATH)); do \
- cp -f $${dts} $(LINUX_ARCH_PATH)/boot/dts/ ; \
- done
+ $(foreach dts,$(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_DTS_PATH)), \
+ cp -f $(dts) $(LINUX_ARCH_PATH)/boot/dts/
+ )
$(LINUX_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) $(LINUX_TARGET_NAME)
@if grep -q "CONFIG_MODULES=y" $(@D)/.config; then \
$(LINUX_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) modules ; \
OpenPOWER on IntegriCloud