summaryrefslogtreecommitdiffstats
path: root/linux/linux-ext-aufs.mk
diff options
context:
space:
mode:
authorChristian Stewart <christian@paral.in>2016-07-17 14:50:37 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-09-20 19:03:46 +0200
commit010588c1e169843bdca35c71789a16d0b6829bcb (patch)
tree87e398418a1d2b5061cf0dc8a8d6bd0721de28bf /linux/linux-ext-aufs.mk
parentc4f453fd7e84617bd2082ebff0cdb526b6afd952 (diff)
downloadbuildroot-010588c1e169843bdca35c71789a16d0b6829bcb.tar.gz
buildroot-010588c1e169843bdca35c71789a16d0b6829bcb.zip
aufs: new kernel extension
Signed-off-by: Christian Stewart <christian@paral.in> [Atul: - Removed the duplicate conditional block. - Updated the license to GPLv2. - Removed the visibilty of package from menuconfig. - Removed dependencies. - Removed the comment. - Changed the name of variable from BR2_PACKAGE_AUFS_STANDALONE_VERSION to BR2_LINUX_KERNEL_EXT_AUFS_VERSION. - Removed the AUFS_INSTALL_STAGING and AUFS_INSTALL_TARGET variables. - Removed the BR2_PACKAGE_AUFS_3X and BR2_PACKAGE_AUFS_4X variables.] Signed-off-by: Atul Singh <atul.singh.mandla@rockwellcollins.com> [yann.morin.1998@free.fr: - do not fail on version check if aufs ext is disabled - check for empty version - squash aufs package and linux extension in one patch - fail if the kernel already has aufs support - simplify handling of version] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> [Thomas: - Fix the apply patch logic, it was using a non-existent AUFS_VERSION_MAJOR variable. BR2_PACKAGE_AUFS_SERIES is used instead.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux/linux-ext-aufs.mk')
-rw-r--r--linux/linux-ext-aufs.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/linux/linux-ext-aufs.mk b/linux/linux-ext-aufs.mk
new file mode 100644
index 0000000000..fb2f3560a7
--- /dev/null
+++ b/linux/linux-ext-aufs.mk
@@ -0,0 +1,21 @@
+################################################################################
+# Linux Aufs extensions
+#
+# Patch the linux kernel with aufs extension
+################################################################################
+
+LINUX_EXTENSIONS += aufs
+
+define AUFS_PREPARE_KERNEL
+ if test -d $(@D)/fs/aufs/; then \
+ echo "Your kernel already supports AUFS."; \
+ exit 1; \
+ fi
+ $(APPLY_PATCHES) $(@D) $(AUFS_DIR) \
+ aufs$(BR2_PACKAGE_AUFS_SERIES)-kbuild.patch \
+ aufs$(BR2_PACKAGE_AUFS_SERIES)-base.patch \
+ aufs$(BR2_PACKAGE_AUFS_SERIES)-mmap.patch \
+ aufs$(BR2_PACKAGE_AUFS_SERIES)-standalone.patch
+ cp -r $(AUFS_DIR)/fs/aufs/ $(@D)/fs/
+ cp $(AUFS_DIR)/include/uapi/linux/aufs_type.h $(@D)/include/uapi/linux/
+endef
OpenPOWER on IntegriCloud