summaryrefslogtreecommitdiffstats
path: root/fs
diff options
context:
space:
mode:
authorSébastien Szymanski <sebastien.szymanski@armadeus.com>2017-03-24 17:20:29 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-03-25 14:41:05 +0100
commitc6bca8cef0310bc649240b451989457ce94a8358 (patch)
treec209d47ebb167a157caea45d9b04ca95ef8915d5 /fs
parenta655a74d1aaf77ea5e38b5965f9e0b8aac7681b7 (diff)
downloadbuildroot-c6bca8cef0310bc649240b451989457ce94a8358.tar.gz
buildroot-c6bca8cef0310bc649240b451989457ce94a8358.zip
fs/ext2: Remove support for auto-calculation of rootfs size
Auto-calculation of the rootfs size cannot be done in a reliable way as it depends on the host filesystem and is broken on non ext4 host (see bugs [1] [2]). So let the user specify the size he wants for his rootfs. [1] https://bugs.busybox.net/show_bug.cgi?id=8831 [2] https://bugs.busybox.net/show_bug.cgi?id=9496 Signed-off-by: Sébastien Szymanski <sebastien.szymanski@armadeus.com> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> [Thomas: as suggested by Arnout, use 60 MB as the default size instead of 64 MB.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs')
-rw-r--r--fs/ext2/Config.in13
-rw-r--r--fs/ext2/ext2.mk1
2 files changed, 3 insertions, 11 deletions
diff --git a/fs/ext2/Config.in b/fs/ext2/Config.in
index b8eeed25d4..19ed140c88 100644
--- a/fs/ext2/Config.in
+++ b/fs/ext2/Config.in
@@ -44,22 +44,15 @@ config BR2_TARGET_ROOTFS_EXT2_REV
config BR2_TARGET_ROOTFS_EXT2_LABEL
string "filesystem label"
+# 61440 = 60MB, i.e usually small enough to fit on a 64MB media
config BR2_TARGET_ROOTFS_EXT2_BLOCKS
- int "exact size in blocks (leave at 0 for auto calculation)"
- default 0
+ int "exact size in blocks"
+ default 61440
config BR2_TARGET_ROOTFS_EXT2_INODES
int "exact number of inodes (leave at 0 for auto calculation)"
default 0
-config BR2_TARGET_ROOTFS_EXT2_EXTRA_BLOCKS
- int "extra size in blocks" if BR2_TARGET_ROOTFS_EXT2_BLOCKS = 0
- default 0
- help
- Enter here the number of extra blocks of free space you
- want on your filesystem. By default, Buildroot will not
- leave much space free.
-
config BR2_TARGET_ROOTFS_EXT2_EXTRA_INODES
int "extra inodes" if BR2_TARGET_ROOTFS_EXT2_INODES = 0
default 0
diff --git a/fs/ext2/ext2.mk b/fs/ext2/ext2.mk
index cfb34c4565..30f1d17b95 100644
--- a/fs/ext2/ext2.mk
+++ b/fs/ext2/ext2.mk
@@ -9,7 +9,6 @@ EXT2_OPTS = -G $(BR2_TARGET_ROOTFS_EXT2_GEN) -R $(BR2_TARGET_ROOTFS_EXT2_REV)
ifneq ($(strip $(BR2_TARGET_ROOTFS_EXT2_BLOCKS)),0)
EXT2_OPTS += -b $(BR2_TARGET_ROOTFS_EXT2_BLOCKS)
endif
-EXT2_OPTS += -B $(BR2_TARGET_ROOTFS_EXT2_EXTRA_BLOCKS)
ifneq ($(strip $(BR2_TARGET_ROOTFS_EXT2_INODES)),0)
EXT2_OPTS += -i $(BR2_TARGET_ROOTFS_EXT2_INODES)
OpenPOWER on IntegriCloud