summaryrefslogtreecommitdiffstats
path: root/fs
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2017-08-06 17:41:02 +0200
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2017-08-09 23:57:35 +0200
commit62e626b2ab9f60b21b8c8c392b0dc4ccd509f69b (patch)
tree845c44687d8633072263031d5ca4efe7781fb63b /fs
parent6e661afd27c8edebe42246e14614cb0299ec835c (diff)
downloadbuildroot-62e626b2ab9f60b21b8c8c392b0dc4ccd509f69b.tar.gz
buildroot-62e626b2ab9f60b21b8c8c392b0dc4ccd509f69b.zip
fs/squashfs: honour the number of parallel jobs
By default, mksquashfs uses all the CPUs available, like us with BR2_JLEVEL=0. However, by setting BR21_JLEVEL to non-zero, a user volutarily limits the number of jobbs allowed to run concurrently (for various reasons, like this is not a priority task on the machine; or like the autobuilders, to spread the load accross multiple runs without overloading the machine). So, propagate tthe parallelisn settings down to mksquashfs, to repect the user's will. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Clayton Shotwell <clayton.shotwell@rockwellcollins.com> Tested-by: Clayton Shotwell <clayton.shotwell@rockwellcollins.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Diffstat (limited to 'fs')
-rw-r--r--fs/squashfs/squashfs.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/fs/squashfs/squashfs.mk b/fs/squashfs/squashfs.mk
index 342c7a8a37..7de7f51af1 100644
--- a/fs/squashfs/squashfs.mk
+++ b/fs/squashfs/squashfs.mk
@@ -6,6 +6,8 @@
ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs
+ROOTFS_SQUASHFS_ARGS = -noappend -processors $(PARALLEL_JOBS)
+
ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZ4),y)
ROOTFS_SQUASHFS_ARGS += -comp lz4 -Xhc
else ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZO),y)
@@ -19,8 +21,7 @@ ROOTFS_SQUASHFS_ARGS += -comp gzip
endif
define ROOTFS_SQUASHFS_CMD
- $(HOST_DIR)/bin/mksquashfs $(TARGET_DIR) $@ -noappend \
- $(ROOTFS_SQUASHFS_ARGS)
+ $(HOST_DIR)/bin/mksquashfs $(TARGET_DIR) $@ $(ROOTFS_SQUASHFS_ARGS)
endef
$(eval $(call ROOTFS_TARGET,squashfs))
OpenPOWER on IntegriCloud