summaryrefslogtreecommitdiffstats
path: root/fs
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2017-10-13 21:16:52 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2018-01-08 23:43:58 +0100
commit51fa8d8e2892d10981fb4f70e24789aea3b4385c (patch)
tree777b6b1b496522ffc19c9c2cbc5131790d404998 /fs
parent390780d5626f5d8613dab22928ae90051d169ab1 (diff)
downloadbuildroot-51fa8d8e2892d10981fb4f70e24789aea3b4385c.tar.gz
buildroot-51fa8d8e2892d10981fb4f70e24789aea3b4385c.zip
fs/common.mk: support lz4 compression
Similar to the other compressors. Notice that we use the -l (legacy format) for Linux kernel initrd compatibility. Lz4 decompression is supported by the Linux kernel since 3.11. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs')
-rw-r--r--fs/common.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/fs/common.mk b/fs/common.mk
index 98232f0b9f..9715eb13d9 100644
--- a/fs/common.mk
+++ b/fs/common.mk
@@ -56,6 +56,11 @@ ROOTFS_$(2)_DEPENDENCIES += host-lzma
ROOTFS_$(2)_COMPRESS_EXT = .lzma
ROOTFS_$(2)_COMPRESS_CMD = $$(LZMA) -9 -c
endif
+ifeq ($$(BR2_TARGET_ROOTFS_$(2)_LZ4),y)
+ROOTFS_$(2)_DEPENDENCIES += host-lz4
+ROOTFS_$(2)_COMPRESS_EXT = .lz4
+ROOTFS_$(2)_COMPRESS_CMD = lz4 -l -9 -c
+endif
ifeq ($$(BR2_TARGET_ROOTFS_$(2)_LZO),y)
ROOTFS_$(2)_DEPENDENCIES += host-lzop
ROOTFS_$(2)_COMPRESS_EXT = .lzo
OpenPOWER on IntegriCloud