summaryrefslogtreecommitdiffstats
path: root/fs
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2017-07-05 13:14:19 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-07-05 15:19:29 +0200
commit0f9c0bf3d5cdd2f99b66da7ab7e23c7b2bfb8c69 (patch)
treea46d61c940c17cf2b3f5c04bc26f0c7a8b1f9730 /fs
parent15bff58f3e627fc328dd2614fabbbae70113794b (diff)
downloadbuildroot-0f9c0bf3d5cdd2f99b66da7ab7e23c7b2bfb8c69.tar.gz
buildroot-0f9c0bf3d5cdd2f99b66da7ab7e23c7b2bfb8c69.zip
Globally replace $(HOST_DIR)/usr/bin with $(HOST_DIR)/bin
Since things are no longer installed in $(HOST_DIR)/usr, the callers should also not refer to it. This is a mechanical change with git grep -l '$(HOST_DIR)/usr/bin' | xargs sed -i 's%$(HOST_DIR)/usr/bin%$(HOST_DIR)/bin%g' Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs')
-rw-r--r--fs/axfs/axfs.mk2
-rw-r--r--fs/cloop/cloop.mk4
-rw-r--r--fs/common.mk4
-rw-r--r--fs/cramfs/cramfs.mk2
-rw-r--r--fs/iso9660/iso9660.mk4
-rw-r--r--fs/romfs/romfs.mk2
-rw-r--r--fs/squashfs/squashfs.mk2
-rw-r--r--fs/yaffs2/yaffs.mk2
8 files changed, 11 insertions, 11 deletions
diff --git a/fs/axfs/axfs.mk b/fs/axfs/axfs.mk
index 05d6e5d395..6c795d7062 100644
--- a/fs/axfs/axfs.mk
+++ b/fs/axfs/axfs.mk
@@ -7,7 +7,7 @@
ROOTFS_AXFS_DEPENDENCIES = host-axfsutils
define ROOTFS_AXFS_CMD
- $(HOST_DIR)/usr/bin/mkfs.axfs -s -a $(TARGET_DIR) $@
+ $(HOST_DIR)/bin/mkfs.axfs -s -a $(TARGET_DIR) $@
endef
$(eval $(call ROOTFS_TARGET,axfs))
diff --git a/fs/cloop/cloop.mk b/fs/cloop/cloop.mk
index 9e42a3a27f..cbfc79b0d1 100644
--- a/fs/cloop/cloop.mk
+++ b/fs/cloop/cloop.mk
@@ -7,8 +7,8 @@
ROOTFS_CLOOP_DEPENDENCIES = host-cloop host-cdrkit
define ROOTFS_CLOOP_CMD
- $(HOST_DIR)/usr/bin/genisoimage -r $(TARGET_DIR) | \
- $(HOST_DIR)/usr/bin/create_compressed_fs - 65536 > $@
+ $(HOST_DIR)/bin/genisoimage -r $(TARGET_DIR) | \
+ $(HOST_DIR)/bin/create_compressed_fs - 65536 > $@
endef
$(eval $(call ROOTFS_TARGET,cloop))
diff --git a/fs/common.mk b/fs/common.mk
index 396b1c2bdf..14e0a6b868 100644
--- a/fs/common.mk
+++ b/fs/common.mk
@@ -91,7 +91,7 @@ ifeq ($$(BR2_ROOTFS_DEVICE_CREATION_STATIC),y)
endif
endif
$$(call PRINTF,$$(PACKAGES_PERMISSIONS_TABLE)) >> $$(FULL_DEVICE_TABLE)
- echo "$$(HOST_DIR)/usr/bin/makedevs -d $$(FULL_DEVICE_TABLE) $$(TARGET_DIR)" >> $$(FAKEROOT_SCRIPT)
+ echo "$$(HOST_DIR)/bin/makedevs -d $$(FULL_DEVICE_TABLE) $$(TARGET_DIR)" >> $$(FAKEROOT_SCRIPT)
$$(foreach s,$$(call qstrip,$$(BR2_ROOTFS_POST_FAKEROOT_SCRIPT)),\
echo "echo '$$(TERM_BOLD)>>> Executing fakeroot script $$(s)$$(TERM_RESET)'" >> $$(FAKEROOT_SCRIPT); \
echo $$(s) $$(TARGET_DIR) $$(BR2_ROOTFS_POST_SCRIPT_ARGS) >> $$(FAKEROOT_SCRIPT)$$(sep))
@@ -100,7 +100,7 @@ ifeq ($$(BR2_REPRODUCIBLE),y)
endif
$$(call PRINTF,$$(ROOTFS_$(2)_CMD)) >> $$(FAKEROOT_SCRIPT)
chmod a+x $$(FAKEROOT_SCRIPT)
- PATH=$$(BR_PATH) $$(HOST_DIR)/usr/bin/fakeroot -- $$(FAKEROOT_SCRIPT)
+ PATH=$$(BR_PATH) $$(HOST_DIR)/bin/fakeroot -- $$(FAKEROOT_SCRIPT)
$$(INSTALL) -m 0644 support/misc/target-dir-warning.txt $$(TARGET_DIR_WARNING_FILE)
-@rm -f $$(FAKEROOT_SCRIPT) $$(FULL_DEVICE_TABLE)
ifneq ($$(ROOTFS_$(2)_COMPRESS_CMD),)
diff --git a/fs/cramfs/cramfs.mk b/fs/cramfs/cramfs.mk
index 747237290f..85b98b8ccd 100644
--- a/fs/cramfs/cramfs.mk
+++ b/fs/cramfs/cramfs.mk
@@ -11,7 +11,7 @@ CRAMFS_OPTS = -l
endif
define ROOTFS_CRAMFS_CMD
- $(HOST_DIR)/usr/bin/mkcramfs $(CRAMFS_OPTS) $(TARGET_DIR) $@
+ $(HOST_DIR)/bin/mkcramfs $(CRAMFS_OPTS) $(TARGET_DIR) $@
endef
ROOTFS_CRAMFS_DEPENDENCIES = host-cramfs
diff --git a/fs/iso9660/iso9660.mk b/fs/iso9660/iso9660.mk
index d1d9cbf1a4..fec6fe17c2 100644
--- a/fs/iso9660/iso9660.mk
+++ b/fs/iso9660/iso9660.mk
@@ -144,14 +144,14 @@ endif # ROOTFS_ISO9660_USE_INITRD
define ROOTFS_ISO9660_CMD
- $(HOST_DIR)/usr/bin/genisoimage -J -R -b $(ROOTFS_ISO9660_BOOT_IMAGE) \
+ $(HOST_DIR)/bin/genisoimage -J -R -b $(ROOTFS_ISO9660_BOOT_IMAGE) \
-no-emul-boot -boot-load-size 4 -boot-info-table \
-o $@ $(ROOTFS_ISO9660_TARGET_DIR)
endef
ifeq ($(BR2_TARGET_ROOTFS_ISO9660_HYBRID),y)
define ROOTFS_ISO9660_GEN_HYBRID
- $(HOST_DIR)/usr/bin/isohybrid -t 0x96 $@
+ $(HOST_DIR)/bin/isohybrid -t 0x96 $@
endef
ROOTFS_ISO9660_POST_GEN_HOOKS += ROOTFS_ISO9660_GEN_HYBRID
diff --git a/fs/romfs/romfs.mk b/fs/romfs/romfs.mk
index 2738b6b292..eded91df0a 100644
--- a/fs/romfs/romfs.mk
+++ b/fs/romfs/romfs.mk
@@ -7,7 +7,7 @@
ROOTFS_ROMFS_DEPENDENCIES = host-genromfs
define ROOTFS_ROMFS_CMD
- $(HOST_DIR)/usr/bin/genromfs -d $(TARGET_DIR) -f $@
+ $(HOST_DIR)/bin/genromfs -d $(TARGET_DIR) -f $@
endef
$(eval $(call ROOTFS_TARGET,romfs))
diff --git a/fs/squashfs/squashfs.mk b/fs/squashfs/squashfs.mk
index c4d9ca50b3..68a57b074a 100644
--- a/fs/squashfs/squashfs.mk
+++ b/fs/squashfs/squashfs.mk
@@ -25,7 +25,7 @@ endif
endif
define ROOTFS_SQUASHFS_CMD
- $(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $@ -noappend \
+ $(HOST_DIR)/bin/mksquashfs $(TARGET_DIR) $@ -noappend \
$(ROOTFS_SQUASHFS_ARGS)
endef
diff --git a/fs/yaffs2/yaffs.mk b/fs/yaffs2/yaffs.mk
index 19bdbe842e..30570735fa 100644
--- a/fs/yaffs2/yaffs.mk
+++ b/fs/yaffs2/yaffs.mk
@@ -7,7 +7,7 @@
ROOTFS_YAFFS2_DEPENDENCIES = host-yaffs2utils
define ROOTFS_YAFFS2_CMD
- $(HOST_DIR)/usr/bin/mkyaffs2 --all-root $(TARGET_DIR) $@
+ $(HOST_DIR)/bin/mkyaffs2 --all-root $(TARGET_DIR) $@
endef
$(eval $(call ROOTFS_TARGET,yaffs2))
OpenPOWER on IntegriCloud