summaryrefslogtreecommitdiffstats
path: root/fs/iso9660/iso9660.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-06-09 00:21:45 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-06-14 23:24:45 +0200
commitf9ac784ee68057715ce2f61ad8156228b4e0ddf4 (patch)
tree8ab8158fcbcb2be24bf98223f9bf029cd60c060d /fs/iso9660/iso9660.mk
parentbd256e96c07c31b3804e079dd498fe4a4012b64e (diff)
downloadbuildroot-f9ac784ee68057715ce2f61ad8156228b4e0ddf4.tar.gz
buildroot-f9ac784ee68057715ce2f61ad8156228b4e0ddf4.zip
fs/iso9660: add isolinux support
After all the preparation commits, this commit finally adds the iso9660 support itself. Besides adding a new Config.in entry, a little bit of .mk code and the isolinux.cfg default configuration, not much is needed. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'fs/iso9660/iso9660.mk')
-rw-r--r--fs/iso9660/iso9660.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/fs/iso9660/iso9660.mk b/fs/iso9660/iso9660.mk
index 6a1b214b00..588e07bf83 100644
--- a/fs/iso9660/iso9660.mk
+++ b/fs/iso9660/iso9660.mk
@@ -53,6 +53,17 @@ define ROOTFS_ISO9660_INSTALL_BOOTLOADER
$(INSTALL) -D -m 0644 $(GRUB_DIR)/stage2/stage2_eltorito \
$(ROOTFS_ISO9660_TARGET_DIR)/boot/grub/stage2_eltorito
endef
+else ifeq ($(BR2_TARGET_ROOTFS_ISO9660_ISOLINUX),y)
+ROOTFS_ISO9660_DEPENDENCIES += syslinux
+ROOTFS_ISO9660_BOOTLOADER_CONFIG_PATH = \
+ $(ROOTFS_ISO9660_TARGET_DIR)/isolinux/isolinux.cfg
+ROOTFS_ISO9660_BOOT_IMAGE = isolinux/isolinux.bin
+define ROOTFS_ISO9660_INSTALL_BOOTLOADER
+ $(INSTALL) -D -m 0644 $(BINARIES_DIR)/syslinux/isolinux.bin \
+ $(ROOTFS_ISO9660_TARGET_DIR)/isolinux/isolinux.bin
+ $(INSTALL) -D -m 0644 $(HOST_DIR)/usr/share/syslinux/ldlinux.c32 \
+ $(ROOTFS_ISO9660_TARGET_DIR)/isolinux/ldlinux.c32
+endef
endif
define ROOTFS_ISO9660_PREPARATION
OpenPOWER on IntegriCloud