summaryrefslogtreecommitdiffstats
path: root/fs/f2fs
diff options
context:
space:
mode:
authorGrzegorz Blach <grzegorz@blach.pl>2018-11-03 15:32:52 +0100
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-11-03 15:32:52 +0100
commit3c66b119ede099d9180c63eb1171250dc6f736b6 (patch)
tree92d687a17ecf0560c1a18bdfb16315f5137a317b /fs/f2fs
parentd4e5c0925afe1a7e6b236e671027ea159b09345e (diff)
downloadbuildroot-3c66b119ede099d9180c63eb1171250dc6f736b6.tar.gz
buildroot-3c66b119ede099d9180c63eb1171250dc6f736b6.zip
fs/f2fs: add option to define list of filesystem features
Signed-off-by: Grzegorz Blach <grzegorz@blach.pl> [Thomas: split from the initial patch from Grzegorz] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'fs/f2fs')
-rw-r--r--fs/f2fs/Config.in7
-rw-r--r--fs/f2fs/f2fs.mk5
2 files changed, 11 insertions, 1 deletions
diff --git a/fs/f2fs/Config.in b/fs/f2fs/Config.in
index 585b32e6a2..8a66645325 100644
--- a/fs/f2fs/Config.in
+++ b/fs/f2fs/Config.in
@@ -42,4 +42,11 @@ config BR2_TARGET_ROOTFS_F2FS_DISCARD
help
Enable or disable discard policy.
+config BR2_TARGET_ROOTFS_F2FS_FEATURES
+ string "filesystem features"
+ help
+ List of features that the F2FS filesystem should support
+ (e.g "encrypt")
+
+
endif # BR2_TARGET_ROOTFS_F2FS
diff --git a/fs/f2fs/f2fs.mk b/fs/f2fs/f2fs.mk
index 558cddf233..63e3cdae7b 100644
--- a/fs/f2fs/f2fs.mk
+++ b/fs/f2fs/f2fs.mk
@@ -25,12 +25,15 @@ else
F2FS_DISCARD = 0
endif
+F2FS_FEATURES = $(call qstrip,$(BR2_TARGET_ROOTFS_F2FS_FEATURES))
+
F2FS_OPTS = \
-f \
-l "$(F2FS_LABEL)" \
-t $(F2FS_DISCARD) \
$(if $(F2FS_COLD_FILES),-e "$(F2FS_COLD_FILES)") \
- $(if $(F2FS_OVERPROVISION),-o $(F2FS_OVERPROVISION))
+ $(if $(F2FS_OVERPROVISION),-o $(F2FS_OVERPROVISION)) \
+ $(if $(F2FS_FEATURES),-O "$(F2FS_FEATURES)")
ROOTFS_F2FS_DEPENDENCIES = host-f2fs-tools
OpenPOWER on IntegriCloud