summaryrefslogtreecommitdiffstats
path: root/docs
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2014-10-03 19:01:49 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-10-12 07:46:27 +0200
commit05d11e19c574c11851c75a53ba0d5f655778679d (patch)
treed319bb45e4bb1a4d4ce92493af69cd1518a53858 /docs
parent5b34e68369652c306a70a134004638139f901ca4 (diff)
downloadbuildroot-05d11e19c574c11851c75a53ba0d5f655778679d.tar.gz
buildroot-05d11e19c574c11851c75a53ba0d5f655778679d.zip
docs/manual: use the new hooks instead of gendoc rules
Also reorder a bit the definition of the variables, to more resemble a package. Yet a bit more... Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Samuel Martin <s.martin49@gmail.com> Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Reviewed-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'docs')
-rw-r--r--docs/manual/manual.mk17
1 files changed, 10 insertions, 7 deletions
diff --git a/docs/manual/manual.mk b/docs/manual/manual.mk
index ee7887c355..e9e0516deb 100644
--- a/docs/manual/manual.mk
+++ b/docs/manual/manual.mk
@@ -151,25 +151,28 @@ endef
# The Buildroot manual
################################################################################
-# Our manual needs to generate lists
-manual-prepare-sources: manual-update-lists
+MANUAL_SOURCES = $(sort $(wildcard docs/manual/*.txt) $(wildcard docs/images/*))
+MANUAL_RESOURCES = $(TOPDIR)/docs/images
+# Our manual needs to generate lists
# Packages included in BR2_EXTERNAL are not part of buildroot, so they
# should not be included in the manual.
-.PHONY: manual-update-lists
-manual-update-lists: manual-check-dependencies-lists $(BUILD_DIR)/docs/$(pkgname)
+define MANUAL_GEN_LISTS
$(Q)$(call MESSAGE,"Updating the manual lists...")
$(Q)BR2_DEFCONFIG="" TOPDIR=$(TOPDIR) O=$(BUILD_DIR)/docs/$(pkgname) \
BR2_EXTERNAL=$(TOPDIR)/support/dummy-external \
python -B $(TOPDIR)/support/scripts/gen-manual-lists.py
+endef
+MANUAL_POST_RSYNC_HOOKS += MANUAL_GEN_LISTS
-manual-check-dependencies-lists:
+# Our list-generating script requires argparse
+define MANUAL_CHECK_LISTS_DEPS
$(Q)if ! python -c "import argparse" >/dev/null 2>&1 ; then \
echo "You need python with argparse on your host to generate" \
"the list of packages in the manual"; \
exit 1; \
fi
+endef
+MANUAL_CHECK_DEPENDENCIES_HOOKS += MANUAL_CHECK_LISTS_DEPS
-MANUAL_SOURCES = $(sort $(wildcard docs/manual/*.txt) $(wildcard docs/images/*))
-MANUAL_RESOURCES = $(TOPDIR)/docs/images
$(eval $(call GENDOC))
OpenPOWER on IntegriCloud