summaryrefslogtreecommitdiffstats
path: root/boot
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-06-11 15:21:30 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-06-11 15:21:30 +0200
commitd98d7d660eb89ec4e179a5bf54b46fe7bbcb127c (patch)
tree1cabc8198c199eadc23d404ba89f4acec028b0fe /boot
parent26d7dcb8ad53fdf40f243a3797025e1682ef4b20 (diff)
downloadbuildroot-d98d7d660eb89ec4e179a5bf54b46fe7bbcb127c.tar.gz
buildroot-d98d7d660eb89ec4e179a5bf54b46fe7bbcb127c.zip
syslinux: add missing dependency on host-util-linux
If util-linux is not installed system-wide on the host, the build fails with: /usr/bin/gcc -Wp,-MT,isohybrid.o,-MMD,./.isohybrid.o.d -O2 -I/home/thomas/projets/buildroot/output/host/usr/include -W -Wall -Wstrict-prototypes -Os -fomit-frame-pointer -D_FILE_OFFSET_BITS=64 -I/home/thomas/projets/buildroot/output/build/syslinux-6.03/utils -c -o isohybrid.o /home/thomas/projets/buildroot/output/build/syslinux-6.03/utils/isohybrid.c /home/thomas/projets/buildroot/output/build/syslinux-6.03/utils/isohybrid.c:40:23: fatal error: uuid/uuid.h: No such file or directory #include <uuid/uuid.h> ^ compilation terminated. Therefore, this commit adds a dependency on host-util-linux, which will ensure that libuuid is available. The resulting isohybrid tool is really installed, and linked with libuuid: $ readelf -d output/host/usr/bin/isohybrid Dynamic section at offset 0x3e00 contains 26 entries: Tag Type Name/Value 0x0000000000000001 (NEEDED) Shared library: [libuuid.so.1] 0x0000000000000001 (NEEDED) Shared library: [libc.so.6] 0x000000000000000f (RPATH) Library rpath: [/home/thomas/projets/buildroot/output/host/usr/lib] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'boot')
-rw-r--r--boot/syslinux/syslinux.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/boot/syslinux/syslinux.mk b/boot/syslinux/syslinux.mk
index 2b3b9a75f4..5a60388022 100644
--- a/boot/syslinux/syslinux.mk
+++ b/boot/syslinux/syslinux.mk
@@ -13,7 +13,8 @@ SYSLINUX_LICENSE_FILES = COPYING
SYSLINUX_INSTALL_IMAGES = YES
-SYSLINUX_DEPENDENCIES = host-nasm host-upx util-linux
+# host-util-linux needed to provide libuuid when building host tools
+SYSLINUX_DEPENDENCIES = host-nasm host-upx util-linux host-util-linux
ifeq ($(BR2_TARGET_SYSLINUX_LEGACY_BIOS),y)
SYSLINUX_TARGET += bios
OpenPOWER on IntegriCloud