summaryrefslogtreecommitdiffstats
path: root/boot/uboot
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2017-03-21 01:07:07 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-06-11 14:15:13 +0200
commit13cd4415726f1f6242d6502c86f47b3408b1a03f (patch)
treef7d4c473113e39d182728615ed8d0b8ea6fb4a76 /boot/uboot
parent24f650aed2d9d92d8cabf0cb160fcf7964f9811e (diff)
downloadbuildroot-13cd4415726f1f6242d6502c86f47b3408b1a03f.tar.gz
buildroot-13cd4415726f1f6242d6502c86f47b3408b1a03f.zip
uboot: exclude from hash check except for latest version
Instead of excluding the hash specifically for the custom tarball and custom version cases, exclude it always except in the one case where we do have a hash: the latest version. This simplifies the code a little because soon we will add hash checks for git as well, so we also need an exclusion in that case. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'boot/uboot')
-rw-r--r--boot/uboot/uboot.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 5320d5c792..904d45a404 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -17,7 +17,6 @@ ifeq ($(UBOOT_VERSION),custom)
UBOOT_TARBALL = $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_TARBALL_LOCATION))
UBOOT_SITE = $(patsubst %/,%,$(dir $(UBOOT_TARBALL)))
UBOOT_SOURCE = $(notdir $(UBOOT_TARBALL))
-BR_NO_CHECK_HASH_FOR += $(UBOOT_SOURCE)
else ifeq ($(BR2_TARGET_UBOOT_CUSTOM_GIT),y)
UBOOT_SITE = $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_REPO_URL))
UBOOT_SITE_METHOD = git
@@ -31,9 +30,10 @@ else
# Handle stable official U-Boot versions
UBOOT_SITE = ftp://ftp.denx.de/pub/u-boot
UBOOT_SOURCE = u-boot-$(UBOOT_VERSION).tar.bz2
-ifeq ($(BR2_TARGET_UBOOT_CUSTOM_VERSION),y)
-BR_NO_CHECK_HASH_FOR += $(UBOOT_SOURCE)
endif
+
+ifeq ($(BR2_TARGET_UBOOT)$(BR2_TARGET_UBOOT_LATEST_VERSION),y)
+BR_NO_CHECK_HASH_FOR += $(UBOOT_SOURCE)
endif
ifeq ($(BR2_TARGET_UBOOT_FORMAT_BIN),y)
OpenPOWER on IntegriCloud