summaryrefslogtreecommitdiffstats
path: root/boot/at91bootstrap/at91bootstrap.mk
diff options
context:
space:
mode:
authorRaptor Engineering Development Team <support@raptorengineering.com>2019-11-05 21:22:28 +0000
committerRaptor Engineering Development Team <support@raptorengineering.com>2019-11-05 21:22:53 +0000
commitf5907d7a3a9b27210bf4e39111bd229ed9079855 (patch)
treea062f7ee561400c4115e6b79da02a41b2958f879 /boot/at91bootstrap/at91bootstrap.mk
parent4b6188e0f2397a013b91105828437c90a3b1dfb7 (diff)
downloadbuildroot-2017.11-op-build.tar.gz
buildroot-2017.11-op-build.zip
Initial pass at removing binary-only, unlicensed, and proprietary packages from buildroot tree2017.11-op-build
Note that DAHDI is only being removed due to poor packaging -- it does not require binary firmware on some cards, but the buildroot packaging for it unconditionally pulls in binary-only firmware regardless.
Diffstat (limited to 'boot/at91bootstrap/at91bootstrap.mk')
-rw-r--r--boot/at91bootstrap/at91bootstrap.mk47
1 files changed, 0 insertions, 47 deletions
diff --git a/boot/at91bootstrap/at91bootstrap.mk b/boot/at91bootstrap/at91bootstrap.mk
deleted file mode 100644
index f6550588d3..0000000000
--- a/boot/at91bootstrap/at91bootstrap.mk
+++ /dev/null
@@ -1,47 +0,0 @@
-################################################################################
-#
-# at91bootstrap
-#
-################################################################################
-
-AT91BOOTSTRAP_VERSION = 1.16
-AT91BOOTSTRAP_SITE = ftp://www.at91.com/pub/at91bootstrap
-AT91BOOTSTRAP_SOURCE = AT91Bootstrap$(AT91BOOTSTRAP_VERSION).zip
-
-AT91BOOTSTRAP_BOARD = $(call qstrip,$(BR2_TARGET_AT91BOOTSTRAP_BOARD))
-AT91BOOTSTRAP_MEMORY = $(call qstrip,$(BR2_TARGET_AT91BOOTSTRAP_MEMORY))
-AT91BOOTSTRAP_MAKE_SUBDIR = board/$(AT91BOOTSTRAP_BOARD)/$(AT91BOOTSTRAP_MEMORY)
-AT91BOOTSTRAP_BINARY = $(AT91BOOTSTRAP_MAKE_SUBDIR)/$(AT91BOOTSTRAP_MEMORY)_$(AT91BOOTSTRAP_BOARD).bin
-
-AT91BOOTSTRAP_INSTALL_IMAGES = YES
-AT91BOOTSTRAP_INSTALL_TARGET = NO
-
-define AT91BOOTSTRAP_EXTRACT_CMDS
- $(UNZIP) -d $(BUILD_DIR) $(DL_DIR)/$(AT91BOOTSTRAP_SOURCE)
- mv $(BUILD_DIR)/Bootstrap-v$(AT91BOOTSTRAP_VERSION)/* $(@D)
- rmdir $(BUILD_DIR)/Bootstrap-v$(AT91BOOTSTRAP_VERSION)
-endef
-
-ifneq ($(call qstrip,$(BR2_TARGET_AT91BOOTSTRAP_CUSTOM_PATCH_DIR)),)
-define AT91BOOTSTRAP_APPLY_CUSTOM_PATCHES
- $(APPLY_PATCHES) $(@D) $(BR2_TARGET_AT91BOOTSTRAP_CUSTOM_PATCH_DIR) \*.patch
-endef
-
-AT91BOOTSTRAP_POST_PATCH_HOOKS += AT91BOOTSTRAP_APPLY_CUSTOM_PATCHES
-endif
-
-define AT91BOOTSTRAP_BUILD_CMDS
- $(MAKE1) CROSS_COMPILE=$(TARGET_CROSS) -C $(@D)/$(AT91BOOTSTRAP_MAKE_SUBDIR)
-endef
-
-define AT91BOOTSTRAP_INSTALL_IMAGES_CMDS
- cp $(@D)/$(AT91BOOTSTRAP_BINARY) $(BINARIES_DIR)
-endef
-
-$(eval $(generic-package))
-
-ifeq ($(BR2_TARGET_AT91BOOTSTRAP)$(BR_BUILDING),yy)
-ifeq ($(AT91BOOTSTRAP_BOARD),)
-$(error No AT91Bootstrap board name set. Check your BR2_TARGET_AT91BOOTSTRAP_BOARD setting)
-endif
-endif
OpenPOWER on IntegriCloud