diff options
author | Thomas Petazzoni <thomas.petazzoni@free-electrons.com> | 2014-10-06 18:16:10 +0200 |
---|---|---|
committer | Thomas Petazzoni <thomas.petazzoni@free-electrons.com> | 2014-10-06 20:58:06 +0200 |
commit | 5c00522972312f164d55f24cc14da6d3af7a6956 (patch) | |
tree | 0bf95a86dafec429cede2d12062dc297783a86f3 /Makefile | |
parent | 23c52855e212aa34d67fd8d791f82aae635a9306 (diff) | |
download | buildroot-5c00522972312f164d55f24cc14da6d3af7a6956.tar.gz buildroot-5c00522972312f164d55f24cc14da6d3af7a6956.zip |
legal-info: fix bug leading to one package not being considered
Due to excessive parenthesis, the TARGETS_LEGAL_INFO expression was
evaluated to something like this:
toolchain-legal-info toolchain-external-legal-info busybox-legal-info zlib-legal-info))
Yes, with the last two parenthesis. This had the effect that the
zlib-legal-info rule was never called: the last package of $(TARGETS)
$(TARGET_HOST_DEPS) $(HOST_DEPS) was never added in the legal-info
information.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Luca Ceresoli <luca@lucaceresoli.net>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -414,7 +414,7 @@ HOST_DEPS = $(sort $(foreach dep,\ HOST_SOURCE += $(addsuffix -source,$(sort $(TARGETS_HOST_DEPS) $(HOST_DEPS))) TARGETS_LEGAL_INFO := $(patsubst %,%-legal-info,\ - $(TARGETS) $(TARGETS_HOST_DEPS) $(HOST_DEPS)))) + $(TARGETS) $(TARGETS_HOST_DEPS) $(HOST_DEPS)) dirs: $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) \ $(HOST_DIR) $(BINARIES_DIR) |