summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-12-05 21:36:32 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-12-05 22:55:36 +0100
commitf7a07f42f70a73806fd2f6bf3662fc6907845fe9 (patch)
tree097c391d69749f10f34bec8843ceaec76b248257
parent41444d7f892b44c87d3b08e7ba1824b9cb9ee9a8 (diff)
downloadbuildroot-f7a07f42f70a73806fd2f6bf3662fc6907845fe9.tar.gz
buildroot-f7a07f42f70a73806fd2f6bf3662fc6907845fe9.zip
vim: be more careful when removing the documentation
The current VIM_REMOVE_DOCS hook removes all .txt files from /usr/share/vim. Unfortunately, this also removes the rgb.txt file, which is needed at runtime for vim, as reported in bug #9466. This commit changes VIM_REMOVE_DOCS to remove only /usr/share/vim/vim*/doc/. Size-wise, it's equivalent because: - We are no longer removing a few README.txt in other directories, taking more space. - We are now removing the /usr/share/vim/vim*/doc/ folder entirely, which contained a few files not named *.txt So overall, the size of /usr/share/vim/ before and after this patch is still 11MB. Fixes bug #9466. Reported-by: Mateusz Furdyna <sir.ferdek@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/vim/vim.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/vim/vim.mk b/package/vim/vim.mk
index d4a1f82028..308855eaee 100644
--- a/package/vim/vim.mk
+++ b/package/vim/vim.mk
@@ -61,7 +61,7 @@ define VIM_INSTALL_RUNTIME_CMDS
endef
define VIM_REMOVE_DOCS
- find $(TARGET_DIR)/usr/share/vim -type f -name "*.txt" -delete
+ $(RM) -rf $(TARGET_DIR)/usr/share/vim/vim*/doc/
endef
# Avoid oopses with vipw/vigr, lack of $EDITOR and 'vi' command expectation
OpenPOWER on IntegriCloud