summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-09-27 21:32:49 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-04 18:56:11 +0200
commitf6fe8932df4b92dcc27ad012e5bd3001ec9acc42 (patch)
tree5b27ec9480983cb9d444bb4804a4829f644248bd
parent220a583eb1662a949148b828125e5ed715cae662 (diff)
downloadbuildroot-f6fe8932df4b92dcc27ad012e5bd3001ec9acc42.tar.gz
buildroot-f6fe8932df4b92dcc27ad012e5bd3001ec9acc42.zip
pkg-generic: add checks on deprecated variables FOO_BAR_OPT
This patch introduces a check for the usage of deprecated variable FOO_BAR_OPT, and suggests to use FOO_BAR_OPTS instead. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/pkg-generic.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index a89425f231..a6d3bb2ba2 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -717,6 +717,18 @@ $$(foreach pkg,$$($(2)_PROVIDES),\
$$(eval $$(call virt-provides-single,$$(pkg),$$(call UPPERCASE,$$(pkg)),$(1))$$(sep)))
endif
+# Ensure unified variable name conventions between all packages
+$(eval $(call check-deprecated-variable,$(2)_MAKE_OPT,$(2)_MAKE_OPTS))
+$(eval $(call check-deprecated-variable,$(2)_INSTALL_OPT,$(2)_INSTALL_OPTS))
+$(eval $(call check-deprecated-variable,$(2)_INSTALL_TARGET_OPT,$(2)_INSTALL_TARGET_OPTS))
+$(eval $(call check-deprecated-variable,$(2)_INSTALL_STAGING_OPT,$(2)_INSTALL_STAGING_OPTS))
+$(eval $(call check-deprecated-variable,$(2)_INSTALL_HOST_OPT,$(2)_INSTALL_HOST_OPTS))
+$(eval $(call check-deprecated-variable,$(2)_AUTORECONF_OPT,$(2)_AUTORECONF_OPTS))
+$(eval $(call check-deprecated-variable,$(2)_CONF_OPT,$(2)_CONF_OPTS))
+$(eval $(call check-deprecated-variable,$(2)_BUILD_OPT,$(2)_BUILD_OPTS))
+$(eval $(call check-deprecated-variable,$(2)_GETTEXTIZE_OPT,$(2)_GETTEXTIZE_OPTS))
+$(eval $(call check-deprecated-variable,$(2)_KCONFIG_OPT,$(2)_KCONFIG_OPTS))
+
TARGETS += $(1)
ifneq ($$($(2)_PERMISSIONS),)
OpenPOWER on IntegriCloud