summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2017-11-19 17:58:23 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-11-22 21:51:08 +0100
commite55d61fb976168f9d9bb9402f4262f03f8f1fcfc (patch)
tree3188e85555bde6ad000c3e96e3299f6e78b41c48
parentbd6187491976cdfb97bcddbeaddf7f8c35f8e391 (diff)
downloadbuildroot-e55d61fb976168f9d9bb9402f4262f03f8f1fcfc.tar.gz
buildroot-e55d61fb976168f9d9bb9402f4262f03f8f1fcfc.zip
webp: add an option to enable webpmux
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/webp/Config.in7
-rw-r--r--package/webp/webp.mk6
2 files changed, 13 insertions, 0 deletions
diff --git a/package/webp/Config.in b/package/webp/Config.in
index 646eb9ef5a..e8263a95f2 100644
--- a/package/webp/Config.in
+++ b/package/webp/Config.in
@@ -15,4 +15,11 @@ config BR2_PACKAGE_WEBP_DEMUX
of an extended format WebP file, which can have features
like color profile, metadata and animation.
+config BR2_PACKAGE_WEBP_MUX
+ bool "webpmux"
+ help
+ Mux is a part of WebPMux for creation and manipulation
+ of an extended format WebP file, which can have features
+ like color profile, metadata and animation.
+
endif
diff --git a/package/webp/webp.mk b/package/webp/webp.mk
index 821302777e..2f3a78c1cc 100644
--- a/package/webp/webp.mk
+++ b/package/webp/webp.mk
@@ -23,6 +23,12 @@ else
WEBP_CONF_OPTS += --disable-libwebpdemux
endif
+ifeq ($(BR2_PACKAGE_WEBP_MUX),y)
+WEBP_CONF_OPTS += --enable-libwebpmux
+else
+WEBP_CONF_OPTS += --disable-libwebpmux
+endif
+
ifeq ($(BR2_PACKAGE_LIBPNG),y)
WEBP_DEPENDENCIES += libpng
WEBP_CONF_ENV += ac_cv_path_LIBPNG_CONFIG=$(STAGING_DIR)/usr/bin/libpng-config
OpenPOWER on IntegriCloud