summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2019-03-26 18:27:04 +0100
committerPeter Korsgaard <peter@korsgaard.com>2019-03-28 10:47:59 +0100
commitd6c086a50e540d955f8dc037d44ca416a74e9fde (patch)
tree42233b606978e221e0c064e0d94ee3e9aa3afa9f
parent2f44db555460a2793a52485a5c46eaa36ab4ca11 (diff)
downloadbuildroot-d6c086a50e540d955f8dc037d44ca416a74e9fde.tar.gz
buildroot-d6c086a50e540d955f8dc037d44ca416a74e9fde.zip
package/git: use pkg-config to get ssl dependencies
On some architectures, atomic binutils are provided by the libatomic library from gcc. Linking with libatomic is therefore necessary, otherwise the build fails with: /home/test/autobuild/run/instance-2/output/host/sparc-buildroot-linux-uclibc/sysroot/usr/lib/libssl.a(ssl_cert.o): In function `CRYPTO_DOWN_REF': /home/test/autobuild/run/instance-2/output/build/libopenssl-1.1.1a/include/internal/refcount.h:50: undefined reference to `__atomic_fetch_sub_4' This is often for example the case on sparcv8 32 bit. To fix this issue, use pkg-config to retrieve openssl dependencies including atomic library, these dependencies must be passed to LIB_4_CRYPTO IN GIT_MAKE_OPTS Fixes: - http://autobuild.buildroot.org/results/3093897d14a854a7252b25b2fa1f8fdcbb26c9b7 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> (cherry picked from commit 1ae9640a9fc11c315aeb989941d9555065da8b24) Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/git/git.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/git/git.mk b/package/git/git.mk
index 9b176d3661..aec30e3eb3 100644
--- a/package/git/git.mk
+++ b/package/git/git.mk
@@ -12,9 +12,9 @@ GIT_LICENSE_FILES = COPYING LGPL-2.1
GIT_DEPENDENCIES = zlib $(TARGET_NLS_DEPENDENCIES)
ifeq ($(BR2_PACKAGE_OPENSSL),y)
-GIT_DEPENDENCIES += openssl
+GIT_DEPENDENCIES += host-pkgconf openssl
GIT_CONF_OPTS += --with-openssl
-GIT_CONF_ENV_LIBS += $(if $(BR2_STATIC_LIBS),-lz)
+GIT_MAKE_OPTS += LIB_4_CRYPTO="`$(PKG_CONFIG_HOST_BINARY) --libs libssl libcrypto`"
else
GIT_CONF_OPTS += --without-openssl
endif
OpenPOWER on IntegriCloud