summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2019-02-15 22:33:15 +0100
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2019-02-24 22:05:18 +0100
commitcd70bde797a3580b27566b302d601ddd7459e910 (patch)
treea04d976321b7d6087cdb44b68c1cd089823bf251
parentf88bf61b2934c00aeff12346c2d7dc45b9ab9cda (diff)
downloadbuildroot-cd70bde797a3580b27566b302d601ddd7459e910.tar.gz
buildroot-cd70bde797a3580b27566b302d601ddd7459e910.zip
package/libcpprestsdk: link with libatomic when needed
On some architectures, atomic binutils are provided by the libatomic library from gcc. Linking with libatomic is therefore necessary, otherwise the build fails with: sparc-buildroot-linux-uclibc/sysroot/lib/libatomic.so.1: error adding symbols: DSO missing from command line This is often for example the case on sparcv8 32 bit. Fixes: - http://autobuild.buildroot.org/results/983537ceb38add50ca0a2316f39a2964db1b83c5 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
-rw-r--r--package/libcpprestsdk/libcpprestsdk.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/libcpprestsdk/libcpprestsdk.mk b/package/libcpprestsdk/libcpprestsdk.mk
index 74c8eec46f..a03e6d250b 100644
--- a/package/libcpprestsdk/libcpprestsdk.mk
+++ b/package/libcpprestsdk/libcpprestsdk.mk
@@ -12,4 +12,8 @@ LIBCPPRESTSDK_SUBDIR = Release
LIBCPPRESTSDK_DEPENDENCIES += host-pkgconf boost openssl zlib
LIBCPPRESTSDK_CONF_OPTS = -DWERROR=OFF -DCPPREST_EXCLUDE_WEBSOCKETS=ON -DBUILD_SAMPLES=OFF
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
+LIBCPPRESTSDK_CONF_OPTS += -DCMAKE_CXX_FLAGS="$(TARGET_CXXFLAGS) -latomic"
+endif
+
$(eval $(cmake-package))
OpenPOWER on IntegriCloud